PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Immer wieder Einträge in der Log Datei



Beowolf
08.01.2014, 00:04
Hallo zusammen.

Ich habe immer wieder folgenden Eintrag im Log-File:


[20-Nov-2013 21:10:23 Europe/Berlin] PHP Warning: require(includes/templates/template_default/templates/tpl_rss_feed_default.php): failed to open stream: No such file or directory in /*/*/*/*/*/includes/templates/theme486_mobile/common/tpl_main_page.php on line 85

Ich habe aber nirgends eine Datei mit dem Namen "tpl_rss_feed_default.php"

Was besagt diese Meldung denn noch?

Grüße
Manfred

klartexter
08.01.2014, 00:24
[20-Nov-2013 21:10:23 Europe/Berlin] PHP Warning: require(includes/templates/template_default/templates/tpl_rss_feed_default.php): failed to open stream: No such file or directory in /*/*/*/*/*/includes/templates/theme486_mobile/common/tpl_main_page.php on line 85

Ich habe aber nirgends eine Datei mit dem Namen "tpl_rss_feed_default.php"

Was besagt diese Meldung denn noch?

Hallo Manfred,

genau das besagt die Meldung doch, dass Dir das File fehlt. Offensichtlich ist in der Datei includes/templates/theme486_mobile/common/tpl_main_page.php in Zeile 85 ein entsprechender Verweis auf diese Datei.

Beowolf
08.01.2014, 10:08
Habe mich wohl etwas falsch ausgedrückt.

Ich habe das Modul "RSS Feed 2.1.4 für Zen-Cart 1.3.9 deutsch" eingebaut.

Dann liegt es wohl daran, das das Modul unter 1.5 nicht richtig läuft.

Denn die Datei ist in dem Modulpaket nicht mit dabei.


Grüße
Manfred

webchills
08.01.2014, 12:15
Dann liegt es wohl daran, das das Modul unter 1.5 nicht richtig läuft.
Nein, es liegt daran, dass Du zusätzlich ein mobiles Template im Ordner includes/templates/theme486_mobile verwendest.
Du musst dann auch bei Modulen, die in die Template Ordner neue Dateien/Ordner legen entsprechend diese neuen Dateien/Ordner auch zusätzlich in includes/templates/theme486_mobile legen.
Also die beim Modul enthaltenen Files/Ordner aus NEUE DATEIEN/includes/templates/DEINTEMPLATE eben auch nach includes/templates/theme486_mobile hochladen insbesondere den Ordner rss_feed

Beowolf
08.01.2014, 12:28
Ok, habe ich jetztn gemacht.

Das erklärt mir aber noch nicht so richtig, wo die Datei "tpl_rss_feed_default.php" dann eigentlich herkommen soll.

Eine Datei mit diesem Namen ist weder in dem Modulpaket vorhanden noch sonstwo in ZenCart.

Wird sie im Betrieb "erzeugt"?


Grüße
Manfred

webchills
08.01.2014, 12:53
Die Datei tpl_rss_feed_default.php gibt es nicht, ist nicht nötig und wird auch nicht erzeugt.
Normalerweise werden Seiten in Zen Cart aus der entsprechenden Templatedatei in includes/templates/DEINTEMPLATE/templates/tpl-irgendwas.php erzeugt.
Das RSS Modul erzeugt die RSS Seite aber aus einer speziellen tpl_main_page.php im Ordner includes/templates/DEINTEMPLATE/rss_feed
Weil die gefehlt hat, hat Zen Cart versucht, die Seite auf normalen Weg zu erzeugen und daher eben die includes/templates/DEINTEMPLATE/tpl_rss_feed_default.php gesucht, nicht gefunden und daher diesen Fehler geschrieben.

Beowolf
08.01.2014, 13:10
Aha, danke für die Erklärung.

Grüße
Manfred

Beowolf
01.04.2014, 11:55
Da doch hin und wieder die Fehlermeldung im LOG auftaucht, habe ich mal weiter nach einer Lösung gesucht.

In einem anderen Forum:

http://www.zen-cart.com/showthread.php?76041-RSS2-Feed-Contribution/page43

Habe ich diesen Hinweis gefunden:

I think I've sussed this. I added the following code to my .htaccess file:


# RSS feeds
RewriteRule ^rss/(.*).xml$ index\.php?main_page=rss_feed&feed=$1

Bis jetzt sind die Fehlermeldung noch nicht wieder aufgetaucht.

Ist das also dann richtig so?

Grüße
Manfred

bumerang24
07.09.2016, 19:59
Hallo zusammen,

Ich habe jede Mernge Log Einträge vom RSS FEEd nach dem Update 154 / 155


[09-Sep-2016 20:01:57 Europe/Vienna] Request URI: /index.php?main_page=rss_feed&feed=products&products_id=260, IP address: 66.249.76.64
#1 fopen() called at [/var/www/clientsZC_SHOP_155/includes/classes/rss_feed.php:347]
#2 rss_feed->rss_feed_out() called at [/var/www/clients/web/ZC_SHOP_155/includes/templates/template_default/rss_feed/tpl_main_page.php:13]
#3 require(/var/www/clients//ZC_SHOP_155/includes/templates/template_default/rss_feed/tpl_main_page.php) called at [/var/www/clients//ZC_SHOP_155/index.php:97]

[09-Sep-2016 20:01:57 Europe/Vienna] PHP Warning: fopen(/var/www/clients//ZC_SHOP_155/cache/rss/rssfeed_fb01145928bd63c9a61f131b1858665a): failed to open stream: No such file or directory in /var/www/clients/client50/web205/web/ZC_SHOP_155/includes/classes/rss_feed.php on line 347

Mein Template ist Antiseptic, habe ich so beim Update mitgenommen.
Es sollten eigentlich auch alle Daten da sein, denke ich mal

Grüße

Guido

bumerang24
15.10.2016, 19:01
Ich verzweifle mit dem RSS Tool noch,

neuer Shop, nichts besonderes drinn, im Gegenteil, sogar fast alles rausgelassen incl. einen Extra Template, aber der Log Ordner läuft über.

Immer der Eintrag jetzt:


[15-Oct-2016 17:42:02 Europe/Vienna] Request URI: /index.php?main_page=rss_feed&feed=products&products_id=23, IP address: 66.249.76.91
#1 fopen() called at [/var/www/clients//web/web/ZC_SHOP_155/includes/classes/rss_feed.php:347]
#2 rss_feed->rss_feed_out() called at [/var/www/clients/50/web/web/ZC_SHOP_155/includes/templates/responsive_classic/rss_feed/tpl_main_page.php:13]
#3 require(/var/www/clients//web/web/ZC_SHOP_155/includes/templates/responsive_classic/rss_feed/tpl_main_page.php) called at [/var/www/clients///web/ZC_SHOP_155/index.php:97]

[15-Oct-2016 17:42:02 Europe/Vienna] PHP Warning: fopen(/var/www/clients//web/web/ZC_SHOP_155/cache/rss/rssfeed_307cc75599e07500a934318a57633f13): failed to open stream: No such file or directory in /var/www/clients//web/ZC_SHOP_155/includes/classes/rss_feed.php on line 347

Ich habe die RSS Daten schon mal aus dem Download hochgeladen, bringt aber auch keinen Erfolg

Was mache ich falsch, oder kann ich ändern?

Grüße

Guido