PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Zen Cart 1.5.5 EZ-Pages und ezpages_v16 Problem



moonbooter
12.02.2017, 14:46
Hallo,
folgendes Problem. Ich habe das Modul "ezpages_v16" installiert und alle Ezpages (Deutsch/Englisch) werden auf einer
Seite angezeigt. Ich hab die Seiten befüllt und die Links via Bannermager über die EZ-Pages Sitebox eingebunden.
Soweit scheint alles OK. Wenn ich nun auf einen Link der Sitebox klicke, erscheint eine leere Website mit folgender
Fehlermeldung: "WARNING: An Error occurred, please refresh the page and try again."

Im Logfile (ist auch als Textfile angehängt) erscheint folgendes:

[12-Feb-2017 12:39:56 MET] Request URI: /ADMINFOLDER/ezpages.php?action=insert, IP address:
#1 trim() called at [serverxxx/ADMINFOLDER/ezpages.php:150]

[12-Feb-2017 12:39:56 MET] PHP Warning: trim() expects parameter 1 to be string, array given in serverxxx/ADMINFOLDER/ezpages.php on line 150
[12-Feb-2017 12:39:56 MET] Request URI: /ADMINFOLDER/ezpages.php?action=insert, IP address: 2a02:908:f762:6c00:8c7c:330f:4849:f45
#1 mysqli_real_escape_string() called at [serverxxx/includes/classes/db/mysql/query_factory.php:122]
#2 queryFactory->prepare_input() called at [serverxxx/includes/classes/db/mysql/query_factory.php:485]
#3 queryFactory->prepareInput() called at [serverxxx/ADMINFOLDER/includes/functions/database.php:108]
#4 zen_db_input() called at [serverxxx/ADMINFOLDER/includes/functions/database.php:30]
#5 zen_db_perform() called at [serverxxx/ADMINFOLDER/ezpages.php:176]

[12-Feb-2017 12:39:56 MET] PHP Warning: mysqli_real_escape_string() expects parameter 2 to be string, array given in serverxxx/includes/classes/db/mysql/query_factory.php on line 122

Setze ich externe Links auf die EZ-Pages, so werden diese korrekt aufgerufen.

Eins noch: Ich habe "Fix/Repair Multi-Language EZ-Pages database table" ausgeführt. Danach erhielten einige EZ-Pages
den Vermerk "(transmate me)", obwohl ein entsprechender Content bereits enthalten war.

Nachtrag: ich habe das Modul in einer frischem Installation getestet: Gleicher Fehler...

Kann mir bitte jemand helfen. Vielen herzlichen Dank vorab :)

moonbooter
12.02.2017, 16:48
Ich habe gerade nochmal alle EZ-Pages gelöscht. In der DB war danach unter "ezpages" und "ezpages_content" kein Eintrag mehr vorhanden.
Dann habe ich das Modul nochmals installiert und einen neuen Eintrag erstellt. Dieser wird auch in der DB korrekt eingetragen:
ein Eintrag in "ezpages" und zwei Einträge in "ezpages_content" mit je der korrekten languages_id.

Trotzdem bleibt der Fehler bestehen.

webchills
17.02.2017, 19:38
Du lädst ein Modul für die amerikanische Zen Cart Version aus dem amerikanischen Donloadbereich unverändert in eine deutsche Zen Cart Version hoch.
Wenn Du dieses Modul in der deutschen Zen Cart Version verwenden willst, dann musst Du es vorher auf die deutsche Zen Cart Version anpassen.