Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: Update auf Version 1.50 mit Problemen

  1. #1
    Padawan Stufe I Avatar von draver
    Registriert seit
    02.02.2006
    Beiträge
    59
    Themen
    16
    DANKE
    0
    Erhaltene Danke: 0

    Standard Update auf Version 1.50 mit Problemen

    Ich wollte meine alte Version 1.37 (bitte nicht schlagen ) updaten auf die neue Version 1.5.

    Dabei habe ich mich an die Anleitung gehalten und das hat soweit auch erstaunlich gut geklappt.

    Zwei Probleme habe ich jetzt allerdings.

    Erstens: Will ich in das Admin Verzeichnis wechseln, so kommt nicht die Admin Oberfläche sondern die Meldung:
    database upgrade required. please run the 1.3.9-to-1.5.0 upgrade via zc_install

    Rufe ich zc_install auf sagt der mir allerdings: Datenbank Informationen -- Upgrade Sniffer Voraussage: *** No upgrade required ***

    Äääääh, was nun? Wie komme ich ins Admin Menü und hat der jetzt das aktuelle Datenbankupdate oder nicht?

    Ein zweites Problem ist, dass ich nach dem Update keine Umlaute mehr angezeigt bekomme, sondern Hieroglyphen.
    Woran könnte das liegen?



  2. #2
    Padawan Stufe I Avatar von draver
    Registriert seit
    02.02.2006
    Beiträge
    59
    Themen
    16
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Das Problem der Umlaute habe ich gelöst.

    Das Problem mit dem Adminzugriff leider noch nicht.
    Die oben genante Meldung kam nur, weil ich vergessen hatte die Config Datei im Admin Bereich auch zu editieren.

    Nach der Änderung bekomme ich jetzt nicht mehr die Fehlermeldung, sondern immer einen error 404.

    Also wenn ich im Browser www.meine-domain.de/admin/ eingebe wird nur die Seite http://www.meine-domain.de/admin/FIL...ALERT_PAGE.php angezeigt.

    Hat da jemand einen Tipp für mich, wie ich da weiter komme?

  3. #3
    Padawan Stufe VI Avatar von jjuno
    Registriert seit
    26.09.2008
    Beiträge
    758
    Themen
    14
    DANKE
    4
    Erhaltene Danke: 45

    Standard

    Error 404 - not found, also Seite bzw. Verzeichniss nicht gefunden.

    Wenn du deinen Admin Ordner nicht während der Installationsroutine umbenannt hast (siehe Sicherheitsproblem), dann hängt diese an deinen admin Ordner eine
    Zahlenreihe. Das heisst, mit dem FTP Programm auf dem Webspace den neuen Namen des Adminordners auslesen. Was aber nicht das umbenennen erspart.

  4. #4
    Padawan Stufe I Avatar von draver
    Registriert seit
    02.02.2006
    Beiträge
    59
    Themen
    16
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Yep, das war es

    Jetzt noch ein weiteres Problem.

    Nur auf der Startseite werden die Meta Tags falsch angezeigt.

    Also im TITEL TAG wird folgendes angezeigt: HOME_PAGE_META_TITLE


    Keywords und description sind auch leer. Wo hat man das noch mal eingestellt?

    Zweites Problem. Der Shop zeigt jetzt Umlaute im Text richtig an aber wenn der Titel des Artikels ein Umlaut hat, dann wird er in im Browsertitel nicht richtig angezeigt.
    Kann man das lösen?

  5. #5
    Padawan Stufe I Avatar von draver
    Registriert seit
    02.02.2006
    Beiträge
    59
    Themen
    16
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Die Probleme sind gelöst soweit, auch wenn das hier weitestgehend ein Monolog war

    Nun aber zu einem größeren Problem.

    Will ich einen Artikel in den Warenkorb legen so wechselt der Shop auf die Seite /shopping_cart.php und sagt mir, das mein Warenkorb leer ist.

    Ich kann also keine Artikel in den Warenkorb legen. Was könnte das sein?

  6. #6
    Padawan Stufe VI Avatar von jjuno
    Registriert seit
    26.09.2008
    Beiträge
    758
    Themen
    14
    DANKE
    4
    Erhaltene Danke: 45

    Standard

    Probleme mit dem Session Cookie?

    Prüfe Admin ->Tools ->Server Info Einstellungen zu Session_Cookie

  7. #7
    Padawan Stufe I Avatar von draver
    Registriert seit
    02.02.2006
    Beiträge
    59
    Themen
    16
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Zitat Zitat von jjuno Beitrag anzeigen
    Probleme mit dem Session Cookie?

    Prüfe Admin ->Tools ->Server Info Einstellungen zu Session_Cookie
    Da geht dann glaube ich PHP Info auf.

    Session_Cookie finde ich da jetzt nicht aber z.B. session.cookie_domain

    Meinst du das?

  8. #8
    Padawan Stufe I Avatar von draver
    Registriert seit
    02.02.2006
    Beiträge
    59
    Themen
    16
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Interessante Sache. Einen Artikel kann nicht normal in den Warenkorb legen.

    Gehe ich allerdings auf die Bewertungen eines Artikels und klicke dann auf "in den Warenkorb", dann funktioniert es.

    Das ist auch mit dem Standardtemplate reproduzierbar.

    Bei normal in den Warenkorb legen kann ich leider nicht sehen , was der macht.

    Wenn ich über die Bewertungen gehe, dann ist die Schaltfläche mit einem Link verknüpft.

    Code:
    http://www.meine-domain.de/index.php?main_page=product_reviews&products_id=70&action=buy_now
    Warum funktioniert nur nicht das normale ablegen in den Warenkorb?

  9. #9
    Padawan Stufe VI Avatar von jjuno
    Registriert seit
    26.09.2008
    Beiträge
    758
    Themen
    14
    DANKE
    4
    Erhaltene Danke: 45

    Standard

    Wenn mehrere Besucher gleichzeitig auf deinem Shop sind, ohne angemeldet zu sein, braucht es eine Identifikationsmarke um die verschiedenen Leute auseinander zu halten. Das erledigt Zen Cart mit dem Session Cookie. Prüfe mal session.use_cookies und session.use_only_cookies sollte beides auf "on" stehen.

  10. #10
    Padawan Stufe I Avatar von draver
    Registriert seit
    02.02.2006
    Beiträge
    59
    Themen
    16
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Yep, stehen beide auf ON.

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Update von Zen Cart 1.3.7 auf die neue Version
    Von holzi im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 3
    Letzter Beitrag: 05.08.2012, 17:38
  2. wiso hebae ich imeer problemen um in der admin zu kommen
    Von jovandeik im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 0
    Letzter Beitrag: 02.02.2010, 13:42
  3. Habe problemen mit versand status wiedergabe
    Von jovandeik im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 4
    Letzter Beitrag: 02.02.2010, 12:57
  4. Version 1.3.7 Update bei deutschen Sprachdateien
    Von web28 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 2
    Letzter Beitrag: 31.01.2007, 17:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1188 vom 02.12.2016
[Download]