Ergebnis 1 bis 10 von 10

Thema: Nach der Instalation von IH keinen Zugriff zum Adminbereich

  1. #1
    Padawan Stufe V Avatar von Beowolf
    Registriert seit
    14.06.2011
    Beiträge
    618
    Themen
    179
    DANKE
    51
    Erhaltene Danke: 14

    Standard Nach der Instalation von IH keinen Zugriff zum Adminbereich

    Hallo,
    ich teste gerade einen neuen Shop.

    Nach der Installation vom IH bekomme ich diese Fehlermeldung.

    "WARNING: An Error occurred, please refresh the page and try again."

    Inhalt der LOG-Datei:

    Code:
    [01-Oct-2012 11:35:50] PHP Fatal error:  1062:Duplicate entry 'WATERMARK_SMALL_IMAGES-43' for key 2 :: INSERT INTO configuration_language (configuration_title, configuration_key, configuration_language_id, configuration_description, last_modified, date_added) VALUES ('IH - Kleine Bilder - Wasserzeichen', 'WATERMARK_SMALL_IMAGES', '43', 'Stellen Sie auf yes, wenn Sie mit Wasserzeichen versehene kleine Bilder anzeigen wollen.', now(), now()); in /home/www/web232/html/feelmasculin/includes/classes/db/mysql/query_factory.php on line 101
    Wo liegt das Problem? Für jede Hilfe wäre ich dankbar.

    Grüße
    Manfred

  2. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.055
    Themen
    81
    DANKE
    3
    Erhaltene Danke: 954

    Standard

    Das ist ganz offensichtlich keine 1.5 Neuinstallation sondern ein Update einer alten Shopversion, in der der Image Handler bereits vorhanden war. Entferne den alten Image Handler komplett (Anleitung und SQL Uninstaller dazu ist im Download Image Handler 3.0 für Zen-Cart 1.3.9 enthalten). Und erst dann den neuen Image Handler hochladen und installieren.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #3
    Padawan Stufe V Avatar von Beowolf
    Registriert seit
    14.06.2011
    Beiträge
    618
    Themen
    179
    DANKE
    51
    Erhaltene Danke: 14
    Erstellt von

    Standard

    Hallo,
    nein, kein Update.

    Ist eine neue 1.5 Installation. Ist erst heute um 9:10 Uhr aufgespielt worden.

    Grüße

  4. #4
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.055
    Themen
    81
    DANKE
    3
    Erhaltene Danke: 954

    Standard

    Irgendwo muss der Eintrag aber herkommen.

    Mit folgendem Befehl entfernst Du alle Image Handler Datenbankeinträge:
    Code:
    ############################################################################
    # Image Handler Cleaner - 2011-06-10 - webchills
    # ENTFERNT ALLE DATENBANKEINTRÄGE VON IMAGE HANDLER VERSIONEN 3.0 UND ÄLTER
    ############################################################################
    
    
    DELETE FROM configuration WHERE configuration_key = 'IH_VERSION';
    DELETE FROM configuration WHERE configuration_key = 'IH_RESIZE';
    DELETE FROM configuration WHERE configuration_key = 'SMALL_IMAGE_FILETYPE';
    DELETE FROM configuration WHERE configuration_key = 'SMALL_IMAGE_BACKGROUND';
    DELETE FROM configuration WHERE configuration_key = 'SMALL_IMAGE_QUALITY';
    DELETE FROM configuration WHERE configuration_key = 'WATERMARK_SMALL_IMAGES';
    DELETE FROM configuration WHERE configuration_key = 'ZOOM_SMALL_IMAGES';
    DELETE FROM configuration WHERE configuration_key = 'ZOOM_IMAGE_SIZE';
    DELETE FROM configuration WHERE configuration_key = 'MEDIUM_IMAGE_FILETYPE';
    DELETE FROM configuration WHERE configuration_key = 'MEDIUM_IMAGE_BACKGROUND';
    DELETE FROM configuration WHERE configuration_key = 'MEDIUM_IMAGE_QUALITY';
    DELETE FROM configuration WHERE configuration_key = 'WATERMARK_MEDIUM_IMAGES';
    DELETE FROM configuration WHERE configuration_key = 'LARGE_IMAGE_FILETYPE';
    DELETE FROM configuration WHERE configuration_key = 'LARGE_IMAGE_BACKGROUND';
    DELETE FROM configuration WHERE configuration_key = 'LARGE_IMAGE_QUALITY';
    DELETE FROM configuration WHERE configuration_key = 'WATERMARK_LARGE_IMAGES';
    DELETE FROM configuration WHERE configuration_key = 'LARGE_IMAGE_MAX_WIDTH';
    DELETE FROM configuration WHERE configuration_key = 'LARGE_IMAGE_MAX_HEIGHT';
    DELETE FROM configuration WHERE configuration_key = 'WATERMARK_GRAVITY';
    DELETE FROM configuration WHERE configuration_key = 'ADDITIONAL_IMAGE_FILETYPE';
    DELETE FROM configuration WHERE configuration_key = 'ADDITIONAL_IMAGE_BACKGROUND';
    DELETE FROM configuration WHERE configuration_key = 'ZOOM_MEDIUM_IMAGES';
    DELETE FROM configuration WHERE configuration_key = 'SMALL_IMAGE_HOTZONE';
    DELETE FROM configuration WHERE configuration_key = 'MEDIUM_IMAGE_HOTZONE';
    DELETE FROM configuration WHERE configuration_key = 'SHOW_UPLOADED_IMAGES';
    DELETE FROM configuration WHERE configuration_key = 'ZOOM_GRAVITY';
    DELETE FROM configuration WHERE configuration_key = 'IMAGE_MANAGER_HANDLER';
    
    DELETE FROM configuration_language WHERE configuration_key = 'IH_VERSION';
    DELETE FROM configuration_language WHERE configuration_key = 'IH_RESIZE';
    DELETE FROM configuration_language WHERE configuration_key = 'SMALL_IMAGE_FILETYPE';
    DELETE FROM configuration_language WHERE configuration_key = 'SMALL_IMAGE_BACKGROUND';
    DELETE FROM configuration_language WHERE configuration_key = 'SMALL_IMAGE_QUALITY';
    DELETE FROM configuration_language WHERE configuration_key = 'WATERMARK_SMALL_IMAGES';
    DELETE FROM configuration_language WHERE configuration_key = 'ZOOM_SMALL_IMAGES';
    DELETE FROM configuration_language WHERE configuration_key = 'ZOOM_IMAGE_SIZE';
    DELETE FROM configuration_language WHERE configuration_key = 'MEDIUM_IMAGE_FILETYPE';
    DELETE FROM configuration_language WHERE configuration_key = 'MEDIUM_IMAGE_BACKGROUND';
    DELETE FROM configuration_language WHERE configuration_key = 'MEDIUM_IMAGE_QUALITY';
    DELETE FROM configuration_language WHERE configuration_key = 'WATERMARK_MEDIUM_IMAGES';
    DELETE FROM configuration_language WHERE configuration_key = 'LARGE_IMAGE_FILETYPE';
    DELETE FROM configuration_language WHERE configuration_key = 'LARGE_IMAGE_BACKGROUND';
    DELETE FROM configuration_language WHERE configuration_key = 'LARGE_IMAGE_QUALITY';
    DELETE FROM configuration_language WHERE configuration_key = 'WATERMARK_LARGE_IMAGES';
    DELETE FROM configuration_language WHERE configuration_key = 'LARGE_IMAGE_MAX_WIDTH';
    DELETE FROM configuration_language WHERE configuration_key = 'LARGE_IMAGE_MAX_HEIGHT';
    DELETE FROM configuration_language WHERE configuration_key = 'WATERMARK_GRAVITY';
    DELETE FROM configuration_language WHERE configuration_key = 'ADDITIONAL_IMAGE_FILETYPE';
    DELETE FROM configuration_language WHERE configuration_key = 'ADDITIONAL_IMAGE_BACKGROUND';
    DELETE FROM configuration_language WHERE configuration_key = 'ZOOM_MEDIUM_IMAGES';
    DELETE FROM configuration_language WHERE configuration_key = 'SMALL_IMAGE_HOTZONE';
    DELETE FROM configuration_language WHERE configuration_key = 'MEDIUM_IMAGE_HOTZONE';
    DELETE FROM configuration_language WHERE configuration_key = 'SHOW_UPLOADED_IMAGES';
    DELETE FROM configuration_language WHERE configuration_key = 'ZOOM_GRAVITY';
    DELETE FROM configuration_language WHERE configuration_key = 'IMAGE_MANAGER_HANDLER';
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  5. #5
    Padawan Stufe V Avatar von Beowolf
    Registriert seit
    14.06.2011
    Beiträge
    618
    Themen
    179
    DANKE
    51
    Erhaltene Danke: 14
    Erstellt von

    Standard

    Danke für die Hilfe.

    Hat auch nicht funktioniert. Habe jetzt den Shop noch einmal neu aufgespielt. Nun läuft alles.

    Es waren ja noch keine Artikel usw. im Shop. So ging das schneller.


    Grüße
    Manfred

  6. #6
    Padawan Anwärter Avatar von ghdienste
    Registriert seit
    15.11.2010
    Beiträge
    3
    Themen
    1
    DANKE
    0
    erhaltene Danke

    Standard Gleiches Problem mit IH 4 nach Neuinstallation- aber anders gelöst

    Hallo, ich habe das exakt gleiche Problem nach erstmaliger Neuinstallation - es erscheint folgender Text in der Log file:

    [06-Oct-2012 23:06:56] PHP Fatal error: 1062uplicate entry 'WATERMARK_SMALL_IMAGES-43' for key 'config_lang' :: INSERT INTO configuration_language (configuration_title, configuration_key, configuration_language_id, configuration_description, last_modified, date_added) VALUES ('IH - Kleine Bilder - Wasserzeichen', 'WATERMARK_SMALL_IMAGES', '43', 'Stellen Sie auf yes, wenn Sie mit Wasserzeichen versehene kleine Bilder anzeigen wollen.', now(), now()); in /home/sadomaso/public_html/gmediaonline/includes/classes/db/mysql/query_factory.php on line 101

    Der admin ist nicht mehr zu öffnen, weisse seite mit error meldung.

    Nach hin- und her probieren habe ich es dann gelöst bekommen.-

    1. ich habe die beiden in IH4 (NEUERE DATEIEN) zuvor hochgeladenen Dateien im Order /includes/modules/IH_INSTALL online gelöscht (additional_images.php und main_product_image.php)
    2. nunmehr besteht wieder zugang zum admin, aber es erscheinen rote fehlermeldungen oben im admin
    3. nun habe ich den in diesem thread abgebildeten Befehl zur löschung aller IH 4 DB-Einträge eingespielt
    4. nunmehr erneut im admin aktualisiert und nunmehr wurde der IH 4 korrekt installiert
    5. es erscheinen aber immer noch fehler-meldungen, hiervon besagt die letzte zeile etwas vom manuellen löschen einer IH 4 datei in includes/auto_loaders
    6. nach manuellem löschen der besagten datei (weiss name der datei leider jetzt nicht mehr) sind alle fehlermeldungen verschgwunden und es funktioniert einwandfrei

    Möglicherweise wird einer der Fachleute daraus schliessen können, wo genau da ein fehler liegt. Ich wollte es nur kurz dokumentieren
    Grüße
    Ulf

  7. Folgender User sagt Danke zu ghdienste für den nützlichen Beitrag:

    Barchi (05.07.2013)

  8. #7
    Padawan Stufe I Avatar von Barchi
    Registriert seit
    19.01.2011
    Beiträge
    31
    Themen
    7
    DANKE
    7
    Erhaltene Danke: 0

    Standard hab das gleiche Problem

    Ich habe leider das gleiche Problem.

    Deshalb jetzt meine Frage - ist die zuvor beschriebene "Problemlösung" sozusagen der Weisheit letzter Schluss?


    Ich möchte - grad weil es ein "frischer" Shop ist - net allzuviel rumdoktern - und war bislang immer gut von euch beraten. Wie soll ich vorgehen?



    Hier die Fehlermeldung:

    [04-Jul-2013 14:35:17 Europe/Vienna] PHP Fatal error: 1062uplicate entry 'WATERMARK_SMALL_IMAGES-43' for key 'config_lang' :: INSERT INTO zc_configuration_language (configuration_title, configuration_key, configuration_language_id, configuration_description, last_modified, date_added) VALUES ('IH - Kleine Bilder - Wasserzeichen', 'WATERMARK_SMALL_IMAGES', '43', 'Stellen Sie auf yes, wenn Sie mit Wasserzeichen versehene kleine Bilder anzeigen wollen.', now(), now()); in /home/.sites/471/site211/web/shop/includes/classes/db/mysql/query_factory.php on line 101

  9. #8
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.055
    Themen
    81
    DANKE
    3
    Erhaltene Danke: 954

    Standard

    Spiele folgenden Befehl über phpMyAdmin ein:
    Code:
    DELETE FROM configuration_language WHERE configuration_key = 'WATERMARK_SMALL_IMAGES';
    Sollten Deine Datenbanktabellen ein Präfix verwenden (z.B. zc_) dann entsprechend ändern z.B. auf:
    Code:
    DELETE FROM zc_configuration_language WHERE configuration_key = 'WATERMARK_SMALL_IMAGES';
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  10. #9
    Padawan Stufe I Avatar von Barchi
    Registriert seit
    19.01.2011
    Beiträge
    31
    Themen
    7
    DANKE
    7
    Erhaltene Danke: 0

    Standard

    Gleich vorweg - das Problem scheint bei mir gelöst zu sein .........


    Vielen Dank für die Mühe - aber der erste Tipp hat nichts daran geändert, dass der Admin-bereich nicht mehr aufgerufen werden konnte.

    Habe mich dann an die bereits beschriebene Vorgehensweise gehalten - aber GsD nicht so viele Fehlermeldungen erhalten.


    • Zuerst die beiden Dateien (additional_images.php und main_product_image.php) aus dem Verzeichnis NEUEDATEIEN\includes\modules\IH_INSTALL\ gelöscht.

    Dann war der Shop wieder im Adminbereich aufrufbar.


    • Dann alle IH-Datenbankeinträge - mit dem Script von Webchills - gelöscht.



    Hab den IH - wieder per FTP draufgespielt ....... dass ich im Adminbereich keine Bilder sehen kann, scheint ein anderes Problem zu sein (aber da es dazu eh schon ein Thema gibt ........ geh ich vorher dort gucken)




    Vielen Dank nochmal

  11. #10
    Padawan Stufe I Avatar von Barchi
    Registriert seit
    19.01.2011
    Beiträge
    31
    Themen
    7
    DANKE
    7
    Erhaltene Danke: 0

    Standard

    Zitat Zitat von Barchi Beitrag anzeigen
    ....... dass ich im Adminbereich keine Bilder sehen kann, scheint ein anderes Problem zu sein (aber da es dazu eh schon ein Thema gibt ........ geh ich vorher dort gucken)
    Vielen Dank nochmal

    Es war die .htaccess - Datei ........ habe die entsprechende Zeile gelöscht ......................


    JETZT läuft alles supi!! *freu*

Ähnliche Themen

  1. komme nach umbennen nicht mehr in den Adminbereich
    Von ooIANoo im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 5
    Letzter Beitrag: 16.03.2012, 00:38
  2. Search Log V2.0 - Error nach Instalation
    Von dagoberti im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 2
    Letzter Beitrag: 08.08.2011, 20:18
  3. Nach DB-Import kein Zugriff mehr auf Admin
    Von Jurasovic im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 2
    Letzter Beitrag: 01.04.2009, 21:41
  4. kann keinen Artikel löschen!
    Von FGeorg im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 5
    Letzter Beitrag: 07.09.2006, 17:28
  5. Fehler nach Installation zum Adminbereich
    Von MZain im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 4
    Letzter Beitrag: 23.06.2006, 09:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1184 vom 01.09.2016
[Download]