Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Neuinstallation + weisse Seite

  1. #1
    Padawan Stufe III Avatar von ralfisi
    Registriert seit
    11.04.2010
    Ort
    Bülach, Schweiz
    Beiträge
    272
    Themen
    23
    DANKE
    16
    Erhaltene Danke: 11

    Standard Neuinstallation + weisse Seite

    Guten Tag zusammen

    ich habe die Version 1.5 auf dem Server genau nach Anleitung installiert. Hat auch wunderbar und schnell geklappt.
    Ins Admin kann ich mich einloggen, funktioniert einwandfrei.

    Beim Aufrufen vom Shop bekomme ich leider eine weisse Seite zu sehen. :-(
    Im Log steht:
    [06-Apr-2013 07:31:31] PHP Warning: require(includes/languages//index.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/www/web297/html/index.php on line 58
    [06-Apr-2013 07:31:31] PHP Warning: require(includes/languages//index.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/www/web297/html/index.php on line 58
    [06-Apr-2013 07:31:31] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/languages//index.php' (include_path='.:/usr/local/php-5.2.17/lib/php') in /home/www/web297/html/index.php on line 58
    Was mich wundert: "languages//index.php" wieso ein // ?
    Im Ordner includes/languages liegt auch kein index.php (auch im Install-File ist die nicht)

    im File /html/index.php ab Zeile 57 steht:
    $language_page_directory = 'includes/languages/' . $language . '/';
    require($language_page_directory . $current_page . '.php');
    require('includes/languages/' . $language . '.php');
    Was muss ich wo ändern damit ich den Shop zu sehen bekomme?

    Vielen Dank für die Hilfe und ein schönes Wochenende wünscht
    ralf

  2. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.079
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Überprüfe in der Administration unter Lokalisation > Sprachen, ob da wirklich bei Deutsch 43 als Ländercode, de als Code und german als Verzeichnis steht. Und bei englisch entsprechend 1 als Ländercode, en als Code und english als Verzeichnis.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #3
    Padawan Stufe III Avatar von ralfisi
    Registriert seit
    11.04.2010
    Ort
    Bülach, Schweiz
    Beiträge
    272
    Themen
    23
    DANKE
    16
    Erhaltene Danke: 11
    Erstellt von

    Standard

    Guten Tag webchills

    vielen Dank für Deine Bemühungen.

    Die Einstellungen sind genau so, dies wurde bei der Installation so eingetragen. Ausser den Shop - Daten habe ich noch nichts an diesem Shop gemacht oder geändert.

    Siehst Du noch einen Grund an was es liegen kann oder soll ich alles platt machen (inkl. DB) und nochmals installieren?

    Zusagen ist, dass bei der Installation 2 Punkte orange angezeigt wurden, die Installation aber ohne Probleme durch lief.
    Register Globals = EIN
    PHP open_basedir Einschränkungen = /usr/local/php/lib/php/:/home/www/:/usr/bin/:/tmp:/usr/local/php52/lib/php/
    Kann dies der "Hänger" sein?

    Ich wünsche einen schönen Tag
    ralf

  4. #4
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.079
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Was ist das denn für ein Server?
    Um Zen Cart zuverlässig betreiben zu können:
    Register Globals Off
    Safe Mode Off

    Überprüfe noch mit phpMyAdmin in der Tabelle configuration den Wert beim configuration_key DEFAULT_LANGUAGE, möglicherweise wurde der bei der Installation nicht gesetzt. Muss de sein
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  5. #5
    Padawan Stufe III Avatar von ralfisi
    Registriert seit
    11.04.2010
    Ort
    Bülach, Schweiz
    Beiträge
    272
    Themen
    23
    DANKE
    16
    Erhaltene Danke: 11
    Erstellt von

    Standard

    Hallo webchills

    ganz vielen Dank für Deine unermüdliche Hilfe Rund um Zen-Cart.

    Der Server ist der gleiche wo "meine" 7 anderen Zen-Cart - Shop's (Version 1.3.9h (Multi-Server)) laufen und die ich in nächster Zeit umstellen muss.
    Der erste Shop unter 1.5 ist jedoch unabhängig davon ... völlig eigenständig, hat nichts mit den 7 zu tun.

    Die von Dir vorgeschlagene Überprüfung mache ich heute Nachmittag und melde mich dazu.

    Weiterhin einen schönen Tag und danke für die Hilfe.
    ralf

    PS
    Soll ich dem Hoster mitteilen er soll die Variablen
    Register Globals Off
    Safe Mode Off
    einstellen?

  6. #6
    Padawan Stufe III Avatar von ralfisi
    Registriert seit
    11.04.2010
    Ort
    Bülach, Schweiz
    Beiträge
    272
    Themen
    23
    DANKE
    16
    Erhaltene Danke: 11
    Erstellt von

    Standard

    Hallo webchils

    Zitat Zitat von webchills Beitrag anzeigen
    Überprüfe noch mit phpMyAdmin in der Tabelle configuration den Wert beim configuration_key DEFAULT_LANGUAGE, möglicherweise wurde der bei der Installation nicht gesetzt. Muss de sein
    Ist es leider auch nicht. Bei "DEFAULT_LANGUAGE" steht 43 wechsle ich auf de kommt eine Fehlermeldung.

    Was nun?
    - alles platt machen und neu installieren wenn der Hoster die beiden Parameter geändert hat?

    Viele Grüsse und besten Dank
    ralf

  7. #7
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.079
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Zitat Zitat von ralfisi Beitrag anzeigen
    Bei "DEFAULT_LANGUAGE" steht 43 wechsle ich auf de kommt eine Fehlermeldung.
    Gemeint ist:
    So muss es aussehen:
    defaultlanguage.jpg
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  8. #8
    Padawan Stufe III Avatar von ralfisi
    Registriert seit
    11.04.2010
    Ort
    Bülach, Schweiz
    Beiträge
    272
    Themen
    23
    DANKE
    16
    Erhaltene Danke: 11
    Erstellt von

    Standard

    Hallo webchils

    danke, der Wert ist gleich. Einzigster Unterschied dass dies bei mir "configuration_id= 200 ist.

    Viele Grüsse
    ralf

  9. #9
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.079
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Dann versteh ich das hier nicht:
    "Bei "DEFAULT_LANGUAGE" steht 43 wechsle ich auf de kommt eine Fehlermeldung"

    Kannst Du die Shopstartseite mal mit folgendem Link aufrufen?:
    index.php?main_page=index&language=de
    Geändert von webchills (06.04.2013 um 16:48 Uhr)
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  10. #10
    Padawan Stufe III Avatar von ralfisi
    Registriert seit
    11.04.2010
    Ort
    Bülach, Schweiz
    Beiträge
    272
    Themen
    23
    DANKE
    16
    Erhaltene Danke: 11
    Erstellt von

    Standard

    Hallo webchils
    da habe ich mich wohl irgendwie verhauen - tut mir leid.
    Es steht in der betreffenden Zeile wirklich ein de drinn.

    Rufe ich die Seite mit dem Parameter auf, bekomme ich auch eine weisse Seite und im log im Ordnder chache steht:
    [06-Apr-2013 17:51:58] PHP Warning: require(includes/languages//index.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/www/web297/html/index.php on line 58
    [06-Apr-2013 17:51:58] PHP Warning: require(includes/languages//index.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/www/web297/html/index.php on line 58
    [06-Apr-2013 17:51:58] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/languages//index.php' (include_path='.:/usr/local/php-5.2.17/lib/php') in /home/www/web297/html/index.php on line 58
    Wieso bin ich nach solanger Zeit der Version 1.5 mit dem Problem der Erste/Einzigste? Installation läuft ja sonst ohne Probleme. *grübel
    Möchtest Du Server - Zugang haben?

    Vielen Dank für Deine Bemühungen
    ralf

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Weisse Seite bei Installation
    Von Polohatzer im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 29
    Letzter Beitrag: 12.02.2012, 15:55
  2. Problem Weisse Seite
    Von engelsspucke im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 1
    Letzter Beitrag: 18.05.2011, 22:05
  3. Nach der Installation - weisse Seite
    Von duffyduck22 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 18
    Letzter Beitrag: 28.09.2010, 12:59
  4. checkout_shipping weisse seite
    Von nMicha im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 5
    Letzter Beitrag: 29.10.2009, 07:44
  5. Admin-bereich = weisse Seite
    Von spanks im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 25
    Letzter Beitrag: 01.09.2005, 13:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1188 vom 02.12.2016
[Download]