Ergebnis 1 bis 2 von 2

Thema: Wichtige Änderung bei PayPal wegen Poodle Sicherheitslücke

  1. #1
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.838
    Themen
    94
    DANKE
    3
    Erhaltene Danke: 1.186

    Ausrufezeichen Wichtige Änderung bei PayPal wegen Poodle Sicherheitslücke

    Aufgrund der kürzlich entdeckten Poodle Sicherheitslücke im SSL 3 Protokoll werden Payment Anbieter zunehmend die Verwendung dieses alten SSL 3 Protokolls deaktivieren.
    PayPal hat mit dieser Umstellung bereits begonnen, daher ist es unbedingt nötig im PayPal Modul von Zen Cart eine Änderung vorzunehmen, falls im Shop PayPal verwendet wird.

    includes/modules/payment/paypal/paypal_curl.php

    ca. Zeile 60 ändern von:
    Code:
    CURLOPT_SSLVERSION => 3,
    auf
    Code:
    CURLOPT_SSLVERSION => 4,
    Betroffen sind alle Zen Cart Versionen, je nach Version kann die Zeilennummer variieren.

    Wenn diese Änderung nicht vorgenommen wird, wird früher oder später bei Bestellungen mit PayPal folgende Fehlermeldung kommen:
    An error occurred when we tried to contact the payment processor. Please try again, select an alternate payment method, or contact the store owner for assistance. () - (35) error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  2. Folgende 7 User sagen Danke zu webchills für den nützlichen Beitrag:

    amatoris (16.10.2014),curach (16.10.2014),cyvase (16.10.2014),fohn (16.10.2014),klartexter (15.10.2014),Stempel-Copy-Druck (16.10.2014),Thommy (15.10.2014)

  3. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.838
    Themen
    94
    DANKE
    3
    Erhaltene Danke: 1.186
    Erstellt von

    Ausrufezeichen

    UPDATE:

    Statt wie oben empfohlen den Wert von 3 auf 4 zu ändern, ist es besser die Zeile ganz auszukommentieren.

    Also ändern von:
    Code:
    CURLOPT_SSLVERSION => 3,
    auf:
    Code:
    //CURLOPT_SSLVERSION => 3,
    PayPal hat die gestrige Änderung kurzfristig wieder rückgängig gemacht, wird sie aber in den nächsten Tagen wieder aktivieren:
    https://www.paypal-community.com/t5/...LE/ba-p/891829

    Daher ist es unbedingt nötig die Änderung vorzunehmen, weil sonst Zahlungen via PayPal nicht mehr möglich sein werden.

    Der aktuelle Zen Cart 1.5.3 Download auf Sourceforge im Downloadbereich enthält diese Änderung bereits (Revision 1056 vom 16.10.2014)
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  4. Folgende 4 User sagen Danke zu webchills für den nützlichen Beitrag:

    fohn (17.10.2014),klartexter (16.10.2014),Peschel (19.10.2014),Thommy (19.10.2014)

Ähnliche Themen

  1. Wichtige Frage
    Von 2fachmama im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 9
    Letzter Beitrag: 26.04.2013, 17:21
  2. Hacker, gehackt, Sicherheitslücke ?
    Von aykatshop im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 17
    Letzter Beitrag: 05.05.2011, 23:08
  3. Sicherheitslücke bei Mail mit php
    Von reniar im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 2
    Letzter Beitrag: 22.11.2010, 09:28
  4. Wichtige Links
    Von detta66 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 0
    Letzter Beitrag: 15.10.2010, 18:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.
Die amerikanische Zen-Cart Version berücksichtigt viele rechtliche Erfordernisse nicht, denen ein Onlineshop im deutschsprachigen Raum unterworfen ist. Daher wurde die deutsche Zen-Cart Version nicht nur bloß ins Deutsche übersetzt, sondern auch funktional auf die Anforderungen, die an Onlineshops in Deutschland, Österreich und der Schweiz gestellt werden, angepasst.

Die amerikanische Version ist extrem abgespeckt und stellt weiterführende Funktionalitäten durch zusätzliche Module bereit, die erst mühsam manuell installiert werden müssen. Zahlreiche häufig genutzte Erweiterungen und eigene Entwicklungen sind in der deutschen Zen Cart Version bereits vorinstalliert.
Die deutsche Zen-Cart Version bietet außerdem einen völlig multilingualen Adminbereich. Weitere für die deutsche Zen Cart Version angepasste Erweiterungen stehen in unserem Downloadbereich zur Verfügung.

Die deutsche Zen Cart Version wird seit 15 Jahren von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.6c deutsch
vom 01.09.2019
[Download]

unterstützen
Unterstütze die Weiterentwicklung der deutschen Zen Cart Version mit einer Spende!

Spende für die Weiterentwicklung der deutschen Zen Cart Version