Ergebnis 1 bis 8 von 8

Thema: update von 1.5.5 auf 1.5.5e

  1. #1
    Padawan Stufe VIII Avatar von amatoris
    Registriert seit
    03.06.2009
    Beiträge
    1.543
    Themen
    163
    DANKE
    58
    Erhaltene Danke: 91

    Standard update von 1.5.5 auf 1.5.5e

    Nachdem ich nun alle Dateien verglich und änderte, die mir wichtig schienen, kann ich mich nicht mehr in den Admin einloggen:

    Forbidden

    You don't have permission to access /shop1/admin1 on this server.


    Da ich im Admin die relevanten Dateien nicht änderte, habe ich den GEÄNDERTE DATEIEN - DEINADMIN so hochgeladen.
    Die zu löschenden Dateien sind gelöscht.

    Wo könnte der Fehler liegen?

  2. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.344
    Themen
    86
    DANKE
    3
    Erhaltene Danke: 1.042

    Standard

    Eine solche Meldung deutet sehr darauf hin, dass die .htaccess im admin Verzeichnis nicht korrekt ist.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #3
    Padawan Stufe VIII Avatar von amatoris
    Registriert seit
    03.06.2009
    Beiträge
    1.543
    Themen
    163
    DANKE
    58
    Erhaltene Danke: 91
    Erstellt von

    Standard

    Ich habe mich nun nochmals mit der Thematik auseinander gesetzt und wenn ich die .htaccess aus demm Update nehme, dann geht nichts, d.h. ich komme nicht in den Admin. Nehme ich wieder die Alte, zum Update, dann komme ich rein. Nur was soll ich jetzt machen? Ich habe davon null Ahnung.

    Bitte um Hilfe, danke.

  4. #4
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.344
    Themen
    86
    DANKE
    3
    Erhaltene Danke: 1.042

    Standard

    Dein Provider ist Strato oder?
    Strato scheint mit solchen Dingen hier nicht klarzukommen
    Code:
    <IfModule mod_authz_core.c>
     <IfModule !mod_authz_core.c>
    Ich habe noch keinen anderen Provider gesehen, bei dem es mit dieser neuen .htaccess im Adminverzeichnis solche Schwierigkeiten geben würde.

    Kläre mal mit Strato was sie an dieser .htaccess nicht mögen.

    Und verwende einfach die aus 1.5.4 weiter, die neue scheint bei diesem Provider eben nicht verwendbar zu sein.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  5. #5
    Padawan Stufe VIII Avatar von amatoris
    Registriert seit
    03.06.2009
    Beiträge
    1.543
    Themen
    163
    DANKE
    58
    Erhaltene Danke: 91
    Erstellt von

    Standard

    Danke.
    hm. Ich habe ja die Alte Version von 1.5.5 Aber ich kann mich daran erinnern, dass Anfang des Jahres ein Update war und ich das einspielen lassen habe. Zumindest, habe ich es gesagt oder geschrieben, und wenn ich die Dateien vergleiche, müsste da ja was passiert sein, schaue ich mir das Copyrightdatum an.

    Die Alte
    Code:
    ## @copyright Copyright 2003-2017 Zen Cart Development Team
    # @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
    # @version GIT: $Id: Author: DrByte  Fri May 17 14:29:18 2013 -0400 Modified in v1.5.2 $
    #
    
    
    AuthType Basic
    AuthName "No access"
    AuthUserFile .htnopasswd
    AuthGroupFile /dev/null
    #Require valid-user
    
    
    
    
    ###############################
    #
    # This is used with Apache WebServers
    #
    # The following blocks direct HTTP requests to all filetypes in this directory recursively, except certain approved exceptions
    # It also prevents the ability of any scripts to run. No type of script, be it PHP, PERL or whatever, can normally be executed if ExecCGI is disabled.
    # Will also prevent people from seeing what is in the dir. and any sub-directories
    #
    # For this to work, you must include either 'All' or at least: 'Limit' and 'Indexes' parameters to the AllowOverride configuration in your apache/conf/httpd.conf file.
    # Additionally, if you want the added protection offered by the OPTIONS directive below, you'll need to add 'Options' to the AllowOverride list, if 'All' is not specified.
    # Example:
    #<Directory "/usr/local/apache/htdocs">
    #  AllowOverride Limit Options Indexes
    #</Directory>
    ###############################
    
    
    # deny *everything*
    <FilesMatch ".*">
      <IfModule mod_authz_core.c>
        Require all denied
      </IfModule>
      <IfModule !mod_authz_core.c>
        Order Allow,Deny
        Deny from all
      </IfModule>
    </FilesMatch>
    
    
    # but now allow just *certain* necessary files:
    <FilesMatch "(?i).*\.(zip|gzip|pdf|mp3|swf|wma|wmv|wav|epub|ogg|webm|m4v|m4a)$">
      <IfModule mod_authz_core.c>
        Require all granted
      </IfModule>
      <IfModule !mod_authz_core.c>
        Order Allow,Deny
        Allow from all
      </IfModule>
    </FilesMatch>
    
    
    <IfModule mod_headers.c>
      <FilesMatch "(?i).*\.(zip|pdf|mp3|swf|wma|wmv|wav|epub|ogg|m4v|m4a)$">
        # tell all downloads to automatically be treated as "save as" instead of launching in an application directly
        # ALERT: ForceType requires Apache2 or later. If using older version of Apache, it will need mod_mime installed. Or just comment out the ForceType line below
        # (to disable, just comment the next 2 lines by adding a '#' at the beginning of each):
        ForceType application/octet-stream
        Header set Content-Disposition attachment
      </FilesMatch>
    </IfModule>
    
    
    IndexIgnore */*
    
    
    
    
    ## NOTE: If you want even greater security to prevent hackers from running scripts in this folder, uncomment the following line (if your hosting company will allow you to use OPTIONS):
    # OPTIONS -Indexes -ExecCGI
    Die Neue
    Code:
    ## @copyright Copyright 2003-2017 Zen Cart Development Team
    # @license http://www.zen-cart-pro.at/license/2_0.txt GNU Public License V2.0
    #
    #
    # This is used with Apache WebServers
    #
    # The following blocks direct HTTP requests to all filetypes in this directory recursively, except certain approved exceptions
    # It also prevents the ability of any scripts to run. No type of script, be it PHP, PERL or whatever, can normally be executed if ExecCGI is disabled.
    # Will also prevent people from seeing what is in the dir. and any sub-directories
    #
    # For this to work, you must include either 'All' or at least: 'Limit' and 'Indexes' parameters to the AllowOverride configuration in your apache/conf/httpd.conf file.
    # Additionally, if you want the added protection offered by the OPTIONS directive below, you'll need to add 'Options' to the AllowOverride list, if 'All' is not specified.
    # Example:
    #<Directory "/usr/local/apache/htdocs">
    #  AllowOverride Limit Options Indexes
    #</Directory>
    ###############################
    
    
    # deny *everything*
    <FilesMatch ".*">
      <IfModule mod_authz_core.c>
        Require all denied
      </IfModule>
      <IfModule !mod_authz_core.c>
        Order Allow,Deny
        Deny from all
      </IfModule>
    </FilesMatch>
    
    
    # but now allow just *certain* necessary files:
    <FilesMatch "(?i).*\.(js|css|jpg|gif|png|otf|cur|map|eot|svg|ttf|woff2?)$">
      <IfModule mod_authz_core.c>
        Require all granted
      </IfModule>
      <IfModule !mod_authz_core.c>
        Order Allow,Deny
        Allow from all
      </IfModule>
    </FilesMatch>
    
    
    IndexIgnore */*
    die aus 1.5.5 r1184 die war nun aber nicht mehr im Adminordner auf dem Server

    Code:
    ## @copyright Copyright 2003-2013 Zen Cart Development Team
    # @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
    # @version GIT: $Id: Author: DrByte  Sat Dec 21 17:00:00 2013 -0500 Modified in v1.5.3 $
    #
    # This is used with Apache WebServers
    #
    # The following blocks direct HTTP requests to all filetypes in this directory recursively, except certain approved exceptions
    # It also prevents the ability of any scripts to run. No type of script, be it PHP, PERL or whatever, can normally be executed if ExecCGI is disabled.
    # Will also prevent people from seeing what is in the dir. and any sub-directories
    #
    # For this to work, you must include either 'All' or at least: 'Limit' and 'Indexes' parameters to the AllowOverride configuration in your apache/conf/httpd.conf file.
    # Additionally, if you want the added protection offered by the OPTIONS directive below, you'll need to add 'Options' to the AllowOverride list, if 'All' is not specified.
    # Example:
    #<Directory "/usr/local/apache/htdocs">
    #  AllowOverride Limit Options Indexes
    #</Directory>
    ###############################
    DirectoryIndex index.php
    
    
    # deny *everything*
    <FilesMatch ".*\..*">
      Order Allow,Deny
      Deny from all
    </FilesMatch>
    
    
    # but now allow just *certain* necessary files:
    <FilesMatch "(?i).*\.(php|js|css|html?|ico|otf|jpe?g|gif|webp|png|swf|flv|xml|xsl)$">
      Order Allow,Deny
      Allow from all
    </FilesMatch>
    
    
    IndexIgnore */*
    
    
    <limit POST PUT>
    order deny,allow
    deny from All
    </limit>
    
    
    
    
    ## NOTE: If you want even greater security to prevent hackers from running scripts in this folder, uncomment the following line (if your hosting company will allow you to use OPTIONS):
    # OPTIONS -Indexes -ExecCGI
    
    
    
    
    
    
    ##################
    ## Optional caching improvements
    ## Requires mod_header and mod_deflate to be enabled within Apache
    ##################
    <IfModule mod_headers.c>
      Header unset Pragma
      FileETag None
      Header unset ETag
      #Header set Cache-Control "no-transform"
      <FilesMatch "(?i).*\.(ico|jpe?g|gif|otf|webp|png|swf|flv|svg|svgz)$">
        Header set Cache-control "max-age=864000, public, must-revalidate"
        Header unset Last-Modified
      </FilesMatch>
      <FilesMatch "(?i).*\.(html|htm|xml|txt|xsl)$">
        Header set Cache-control "max-age=7200, must-revalidate"
      </FilesMatch>
    </IfModule>
    <IfModule mod_deflate.c>
      <FilesMatch "(?i)\.(js|css)$">
        SetOutputFilter DEFLATE
      </FilesMatch>
    </IfModule>
    
    
    ##################
    ## Optional improvements
    ## Requires mod_expires to be enabled within Apache
    ##################
    <ifmodule mod_expires.c>
      ExpiresActive On
      ExpiresDefault A300
      ExpiresByType application/x-javascript A3600
      ExpiresByType text/css A3600
      ExpiresByType image/gif A604800
      ExpiresByType video/x-flv A604800
      ExpiresByType application/pdf A604800
      ExpiresByType text/html A300
      ExpiresByType image/x-icon A86400
      ExpiresByType image/jpeg A2592000
      ExpiresByType image/png A2592000
      ExpiresByType text/cache-manifest "access plus 0 seconds"
    
    
    </ifmodule>
    
    
    
    
    #turn off X-PHP-Originating-Script header when sending emails from admin
    #uncomment to activate:
    # php_flag mail.add_x_header Off
    Ich denke mal, dass es nicht an diesen Befehlen liegt. Ich hatte mit Strato auch noch nicht wirklich Probleme, was die Dinge ausm Shop angeht. Eigentlich war es immer nur mein Unvermögen.

    Die jetzt/Neuste sieht etwas mager gegen die anderen aus.
    Geändert von amatoris (10.08.2017 um 22:39 Uhr)

  6. #6
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.344
    Themen
    86
    DANKE
    3
    Erhaltene Danke: 1.042

    Standard

    Lade doch bitte einfach die aktuelle 1.5.5e aus dem Downloadbereich herunter und verwende die darin enthsltene admin/.htaccess
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  7. #7
    Padawan Stufe VIII Avatar von amatoris
    Registriert seit
    03.06.2009
    Beiträge
    1.543
    Themen
    163
    DANKE
    58
    Erhaltene Danke: 91
    Erstellt von

    Standard

    Danke, die funktioniert.

    Die sind in der neusten Fassung und im Updatepaket verschieden. Habe gerade beide runtergeladen.

  8. #8
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.344
    Themen
    86
    DANKE
    3
    Erhaltene Danke: 1.042

    Standard

    Ist im Updatepaket nun korrigiert
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

Ähnliche Themen

  1. (Zen-Cart 1.5.5) Erneuter Datenbank-Update nach Versions-Update auf 1.5.5
    Von dieterk im Forum Installation / Update
    Antworten: 8
    Letzter Beitrag: 17.01.2017, 11:40
  2. update v1.3.9f auf v1.3.9h
    Von Multidigital im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 3
    Letzter Beitrag: 11.02.2011, 21:44
  3. Update von 1.2.4.1 auf 1.3.9
    Von sabinebongen im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 19
    Letzter Beitrag: 28.01.2011, 19:53
  4. DB Update von 1.2.5 auf 1.3.5
    Von Butzemann im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 17
    Letzter Beitrag: 01.12.2006, 09:37
  5. Update 1.04 auf 1.1.4
    Von KayR im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 2
    Letzter Beitrag: 19.05.2004, 00:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5e deutsch
Revision 1208 vom 20.05.2017
[Download]