Ergebnis 1 bis 8 von 8

Thema: Geht bei meinem Shop nicht

  1. #1
    Padawan Stufe VI Avatar von Beowolf
    Registriert seit
    14.06.2011
    Beiträge
    728
    Themen
    213
    DANKE
    74
    Erhaltene Danke: 13

    Standard Geht bei meinem Shop nicht

    Hallo zusammen,

    ich würde gerne dieses Modul einbauen:

    https://www.zen-cart-pro.at/forum/vb...downloadid=256

    Leider funktioniert es nicht. Trotz Anzeige und Bestätigung des Google Captcha, werden keine Nachrichten versand. Wenn ich die Fehlder unter Kontakt ausfülle und den Catpcha bestätige, lande ich wieder auf meiner Kontaktseite ohne das die Nachrich versendet wird.

    Hat da jemand eine Idee?

    Grüße und Danke
    Manfred

  2. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.526
    Themen
    88
    DANKE
    3
    Erhaltene Danke: 1.113

    Standard

    Admin > Tools > Serverinfo
    Suche nach
    allow_url_fopen

    Ist das On oder Off?
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #3
    Padawan Stufe VI Avatar von Beowolf
    Registriert seit
    14.06.2011
    Beiträge
    728
    Themen
    213
    DANKE
    74
    Erhaltene Danke: 13
    Erstellt von

    Standard

    Hallo Webchills,

    das "allow_url_fopen" wird bei mir in den "Serverinformationen" nicht angezeigt.

    Ich kann das wohl bei meinem Provider direkt umschalten. Auf was muß das denn stehen?

    Grüße
    Manfred

  4. #4
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.526
    Themen
    88
    DANKE
    3
    Erhaltene Danke: 1.113

    Standard

    Steht 100% auf der Seite
    Weiter unten unter Core

    Dieses Modul setzt standardmäßig allow_url_fopen auf On voraus
    So wie Du es beschreibst steht das in Deiner PHP Konfiguration auf Off, dann würde genau das passieren

    Kann vom Provider oder falls Zugriff besteht selbst in der php.ini geändert werden, falls es nicht erlaubt sein sollte.

    Sollte der Provider das nicht zulassen gibt es in der includes/classes/observers/class.google_recaptcha.php alternativ 2 andere Arten des Aufrufs:

    ca. Zeile 30

    Code:
    $recaptcha = new \ReCaptcha\ReCaptcha($privatekey);
            // If file_get_contents() is locked down on your PHP installation to disallow
            // its use with URLs, then you can use the alternative request method instead.
            // This makes use of fsockopen() instead.
            //$recaptcha = new \ReCaptcha\ReCaptcha($privatekey, new \ReCaptcha\RequestMethod\SocketPost());
            // This makes use of curl instead
            //$recaptcha = new \ReCaptcha\ReCaptcha($privatekey, new \ReCaptcha\RequestMethod\Curl());
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  5. Folgender User sagt Danke zu webchills für den nützlichen Beitrag:

    Beowolf (07.03.2018)

  6. #5
    Padawan Stufe VI Avatar von Beowolf
    Registriert seit
    14.06.2011
    Beiträge
    728
    Themen
    213
    DANKE
    74
    Erhaltene Danke: 13
    Erstellt von

    Standard

    Ok, ich versuche noch einmal. Leider aber erst morgen.

    Habe mal die "Serverinformation" als Bild beigefügt. Übersehe ich da etwas?

    Grüße
    Manfred

    Serverinfo.jpg

  7. #6
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.526
    Themen
    88
    DANKE
    3
    Erhaltene Danke: 1.113

    Standard

    Es geht nicht um die Serverinformationen oben sondern um die PHP Informationen weiter unten. Dort steht das.
    Sollte das bei Dir gar nicht aufscheinen und die Seite nach den Serverinformationen aufhören, dann blockt dieser Provider die Anzeige der php info.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  8. #7
    Padawan Stufe VI Avatar von Beowolf
    Registriert seit
    14.06.2011
    Beiträge
    728
    Themen
    213
    DANKE
    74
    Erhaltene Danke: 13
    Erstellt von

    Standard

    Jepp, mehr steht nicht auf der Seite.

    Grüße
    Manfred

  9. #8
    Padawan Stufe VI Avatar von Beowolf
    Registriert seit
    14.06.2011
    Beiträge
    728
    Themen
    213
    DANKE
    74
    Erhaltene Danke: 13
    Erstellt von

    Standard

    Bin gerade noch einmal in meine Providereinstellungen gegangen.

    Dort habe ich jetzt "allow_url_fopen" auf on gestellt.

    Nun geht es.

    Danke für die Hilfe

    Manfred

Ähnliche Themen

  1. Wie lösche ich deaktivierte Artikel aus meinem Shop
    Von spatz im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 0
    Letzter Beitrag: 11.04.2011, 12:49
  2. Shop geht nicht mehr...Provider hat PHP
    Von sternchen11 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 22
    Letzter Beitrag: 10.11.2009, 11:03
  3. shop installiert, Warnung geht nicht weg.
    Von mistahicecream im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 1
    Letzter Beitrag: 05.02.2009, 16:35
  4. Shop Installation auf meinem Computer
    Von Ruroza im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 19
    Letzter Beitrag: 18.01.2009, 17:55
  5. Designer für meinem Shop gesucht
    Von tunextrem im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 3
    Letzter Beitrag: 22.12.2006, 22:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.
Die amerikanische Zen-Cart Version berücksichtigt viele rechtliche Erfordernisse nicht, denen ein Onlineshop im deutschsprachigen Raum unterworfen ist. Daher wurde die deutsche Zen-Cart Version auf die Anforderungen, die an Onlineshops in Deutschland, Österreich und der Schweiz gestellt werden, angepasst.

Die deutsche Zen-Cart Version bietet außerdem einen multilingualen Adminbereich. Dadurch sind auch die in der Datenbank hinterlegten Konfigurationseinstellungen und -beschreibungen auf deutsch. Diese Funktionalität steht natürlich auch für später installierte Erweiterungen zur Verfügung. Die im Downloadbereich von zen-cart-pro.at angebotenen Module berücksichtigen diese Multilanguagefähigkeit und sind alle für die deutsche Zen-Cart Version ausgelegt. Zahlreiche häufig genutzte Erweiterungen sind bereits vorinstalliert.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5f deutsch
Revision 1236 vom 23.06.2018
[Download]

unterstützen
Unterstütze die Weiterentwicklung der deutschen Zen Cart Version mit einer Spende!

Spende für die Weiterentwicklung der deutschen Zen Cart Version