Ergebnis 1 bis 4 von 4

Thema: Datenbankproblem nach Installation von Winchester Template

  1. #1
    Padawan Anwärter Avatar von tjansk
    Registriert seit
    15.03.2018
    Beiträge
    2
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0

    Standard Datenbankproblem nach Installation von Winchester Template

    Hallo,

    habe auf einer frischen ZencartDE Installation "Winchester Responsive" installiert.
    Folgender Fehler tritt auf:
    FEHLER:
    Datenbankabfragen oder Datenbankeinträge schlagen fehl.

    Hinweis für den Shopinhaber:
    Den Grund für diesen Fehler finden Sie in den Errorlogs.
    Gehen Sie so vor wie in den FAQ auf http://error.zen-cart-pro.at beschrieben.

    Kann mir jemand weiterhelfen?
    Log befindet sich im Anhang.
    Siehe http://admm3.tk/ für PhP infos.

    Lg,
    Tjansk
    Angehängte Dateien Angehängte Dateien

  2. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.820
    Themen
    94
    DANKE
    3
    Erhaltene Danke: 1.203

    Standard

    Die Tabelle flexible_footer_menu wird vom Installer nicht angelegt, hängt mit Deiner MySQL Konfiguration zusammen.
    Am besten die Datenbank leeren, Zen Cart neu installieren.

    Bevor dann das Winchester Template erneut installiert wird:
    Ändere ca. Zeile 179 in DEINADMIN/includes/installers/winchester_responsive/1_5.php
    von
    Code:
    date_added datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
    auf
    Code:
    date_added datetime NOT NULL DEFAULT '0001-01-01 00:00:00',
    Template wird bei Gelegenheit mit dieser Änderung in den Downloads aktualisiert.

    Gib bitte Bescheid ob es danach ok ist.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #3
    Padawan Anwärter Avatar von tjansk
    Registriert seit
    15.03.2018
    Beiträge
    2
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Hallo webchills,

    danke für die schnelle Antwort! Hat funktioniert.
    Aber warum funktioniert es?

    Lg,
    Tjansk


  4. #4
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.820
    Themen
    94
    DANKE
    3
    Erhaltene Danke: 1.203

    Standard

    Wenn MySQL 5.7 im strict mode konfiguriert ist, dann werden solche Datumsangaben nicht akzeptiert.
    Diese Datumsangabe ist eh sinnlos und wird in der nächsten Version des Templates entfernt.
    Meist fallen solche veralteten Dinge in Installern ältere Module nicht auf, weil es bei den meisten Providern anders konfiguriert ist oder niedrigere MySQL Versionen verwendet werden

    https://dev.mysql.com/doc/refman/5.7...ql-mode-strict

    Strict mode affects whether the server permits '0000-00-00' as a valid date:
    If strict mode is not enabled, '0000-00-00' is permitted and inserts produce no warning.
    If strict mode is enabled, '0000-00-00' is not permitted and inserts produce an error, unless IGNORE is given as well.
    For INSERT IGNORE and UPDATE IGNORE, '0000-00-00' is permitted and inserts produce a warning.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

Ähnliche Themen

  1. (Zen-Cart 1.5.5) Winchester kopieren und als aktives Template nutzen?
    Von dirkkii im Forum Design & Anpassung
    Antworten: 0
    Letzter Beitrag: 09.12.2016, 20:42
  2. (Zen-Cart 1.5.5) Wichtige Infos und FAQ zum Template Winchester Black
    Von webchills im Forum Winchester Black
    Antworten: 0
    Letzter Beitrag: 02.10.2016, 19:45
  3. Datenbankeinträge Installation Winchester
    Von Clamor im Forum Winchester Responsive
    Antworten: 1
    Letzter Beitrag: 28.09.2016, 21:01
  4. Template Winchester Black 1.4 Sidebox
    Von 9mm im Forum Winchester Black
    Antworten: 1
    Letzter Beitrag: 20.06.2016, 19:26
  5. Antworten: 3
    Letzter Beitrag: 28.09.2015, 21:01

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.
Die amerikanische Zen-Cart Version berücksichtigt viele rechtliche Erfordernisse nicht, denen ein Onlineshop im deutschsprachigen Raum unterworfen ist. Daher wurde die deutsche Zen-Cart Version auf die Anforderungen, die an Onlineshops in Deutschland, Österreich und der Schweiz gestellt werden, angepasst.

Die deutsche Zen-Cart Version bietet außerdem einen multilingualen Adminbereich. Dadurch sind auch die in der Datenbank hinterlegten Konfigurationseinstellungen und -beschreibungen auf deutsch. Diese Funktionalität steht natürlich auch für später installierte Erweiterungen zur Verfügung. Die im Downloadbereich von zen-cart-pro.at angebotenen Module berücksichtigen diese Multilanguagefähigkeit und sind alle für die deutsche Zen-Cart Version ausgelegt. Zahlreiche häufig genutzte Erweiterungen sind bereits vorinstalliert.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5f deutsch
Revision 1242 vom 27.10.2018
[Download]

unterstützen
Unterstütze die Weiterentwicklung der deutschen Zen Cart Version mit einer Spende!

Spende für die Weiterentwicklung der deutschen Zen Cart Version