Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 13 von 13

Thema: Use of undefined constant OFFICE_IP_TO_HOST_ADDRESS nach Update auf 1.5.6.e

  1. #11
    Padawan Anwärter Avatar von Anna779
    Registriert seit
    05.08.2010
    Beiträge
    10
    Themen
    2
    DANKE
    1
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Servus,
    bin dem einen Fehler auf die Schliche gekommen, lag in den email_Templates
    Die Spider logs werden nicht mehr geschrieben.

    Leider bekomme ich nun folgende logs:

    Code:
    [09-Sep-2021 16:55:54 Europe/Berlin] Request URI: /index.php?main_page=privacy, IP address: xxxxxxx
    #1 require(/www/htdocs/xxxxxxx/xxxxxxx/includes/templates/template_default/templates/tpl_privacy_default.php) called at [/www/htdocs/xxxxxxx/xxxxxxx/includes/templates/classic/common/tpl_main_page.php:131]
    #2 require(/www/htdocs/xxxxxxx/xxxxxxx/includes/templates/classic/common/tpl_main_page.php) called at [/www/htdocs/xxxxxxx/xxxxxxx/index.php:97]
    --> PHP Warning: Use of undefined constant IT_RECHT_KANZLEI_STATUS - assumed 'IT_RECHT_KANZLEI_STATUS' (this will throw an Error in a future version of PHP) in /www/htdocs/xxxxxxx/xxxxxxx/includes/templates/template_default/templates/tpl_privacy_default.php on line 24.
    Code:
    [09-Sep-2021 16:55:54 Europe/Berlin] Request URI: /index.php?main_page=privacy, IP address: xxxxxxx
    #1 require(/www/htdocs/xxxxxxx/xxxxxxx/includes/templates/template_default/templates/tpl_privacy_default.php) called at [/www/htdocs/xxxxxxx/xxxxxxx/includes/templates/classic/common/tpl_main_page.php:131]
    #2 require(/www/htdocs/xxxxxxx/xxxxxxx/includes/templates/classic/common/tpl_main_page.php) called at [/www/htdocs/xxxxxxx/xxxxxxx/index.php:97]
    --> PHP Warning: Use of undefined constant IT_RECHT_KANZLEI_STATUS - assumed 'IT_RECHT_KANZLEI_STATUS' (this will throw an Error in a future version of PHP) in /www/htdocs/xxxxxxx/xxxxxxx/includes/templates/template_default/templates/tpl_privacy_default.php on line 16.
    Code:
    [09-Sep-2021 16:55:54 Europe/Berlin] Request URI: /index.php?main_page=privacy, IP address: xxxxxxx
    #1 require(/www/htdocs/xxxxxxx/xxxxxxx/includes/modules/pages/privacy/header_php.php) called at [/www/htdocs/xxxxxxx/xxxxxxx/index.php:36]
    --> PHP Warning: Use of undefined constant IT_RECHT_KANZLEI_STATUS - assumed 'IT_RECHT_KANZLEI_STATUS' (this will throw an Error in a future version of PHP) in /www/htdocs/xxxxxxx/xxxxxxx/includes/modules/pages/privacy/header_php.php on line 12.
    In zen_neu sind in incl\templ.\templ._default viele Dateien, die nicht in incl\templ.\classic/common sind. Liegt da der Fehler?

    und die englischen ezpages funktionieren nicht, DB-Fehler, habe dann in der DB die doppelten Id's (englisch) gelöscht, wenn ich die deutsche ez-page in den Eingabefeldern für englisch bearbeite und absende, DB-Fehler und folgender log:

    Code:
    [07-Sep-2021 17:32:49 Europe/Berlin] Request URI: /xxxxxxx/ezpages.php?action=insert, IP address: xxxxxxx
    #1 trigger_error() called at [/www/htdocs/xxxxxxx/xxxxxxx/includes/classes/db/mysql/query_factory.php:171]
    #2 queryFactory->show_error() called at [/www/htdocs/xxxxxxx/xxxxxxx/includes/classes/db/mysql/query_factory.php:143]
    #3 queryFactory->set_error() called at [/www/htdocs/xxxxxxx/xxxxxxx/includes/classes/db/mysql/query_factory.php:270]
    #4 queryFactory->Execute() called at [/www/htdocs/xxxxxxx/xxxxxxx/xxxxxxx/includes/functions/database.php:51]
    #5 zen_db_perform() called at [/www/htdocs/xxxxxxx/xxxxxxx/xxxxxxx/ezpages.php:152]
    --> PHP Fatal error: 1054:Unknown column 'page_key' in 'field list' :: insert into ezpages (page_open_new_window, page_is_ssl, alt_url, alt_url_external, status_header, status_sidebox, status_footer, status_toc, status_visible, header_sort_order, sidebox_sort_order, footer_sort_order, toc_sort_order, toc_chapter, page_key) values ('1', '1', '', '', '0', '0', '0', '0', '0', '0', '0', '0', '0', '0', '') ==> (as called by) /www/htdocs/xxxxxxx/xxxxxxx/xxxxxxx/includes/functions/database.php on line 51 <== in /www/htdocs/xxxxxxx/xxxxxxx/includes/classes/db/mysql/query_factory.php on line 171.

    Vielen Dank für Hilfe

  2. #12
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    7.199
    Themen
    98
    DANKE
    3
    Erhaltene Danke: 1.324

    Standard

    Wie weiter oben beschrieben:
    Im logs Verzeichnis findest Du detaillierte Logs zum Update, sie beginnen mit zcInstallDEBUG, offensichtlich wurden hier einige Befehle gar nicht ausgeführt oder abgebrochen.
    In Deinem Fall wohl fast alles was 1.5.4 erstmal auf 1.5.5 bringt

    Ohne ein vollständiges Update macht das alles keinen Sinn. Das hat nichts mit irgendwelchen Templates zu tun, hier fehlen ganz grundlegende Datenbankeinträge,

    Spiele den 1.5.4 Dump wieder ein.
    Führe zc_install erneut aus und starte das Update
    Danach gehst Du wirklich in den Ordner logs und siehst Dir die zc_installDEBUG logs mit Datum und Uhrzeit dieses Updates an.
    Hier siehst Du detailliert welche Befehle abgebrochen wurden.
    Die entsprechenden Befehle nimmst Du manuell aus
    zc_install/sql/updates/mysql_upgrade_zencart_155.sql
    Und spielst sie direkt via phpMyAdmin ein
    Sollten auch Befehle aus mysql_upgrade_zencart_156.sql fehlen, die ebenfalls einspielen
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #13
    Padawan Anwärter Avatar von Anna779
    Registriert seit
    05.08.2010
    Beiträge
    10
    Themen
    2
    DANKE
    1
    Erhaltene Danke: 0
    Erstellt von

    Standard Update 1.5.4 auf 1.5.6e

    Servus,
    also ich habe mich jetzt entschlossen, nochmal von vorne zu beginnen und zuerst update auf 1.5.5. zu machen und habe den shop wieder auf 1.5.4 laufen.
    Doch wie zu Anfang schon geschildert, bekomme ich im 1.5.4. nun keine mails mehr, weder Bestellungen noch unter Kontakt. In der DB sind die mails
    gelistet. DB auf utf8_general.ci
    Hat hier im Forum schon mal jemand von 1.5.4 auf 1.5.6e upgedatet?
    Gruss

Seite 2 von 2 ErsteErste 12

Ähnliche Themen

  1. (Zen-Cart 1.5.6) Use of undefined constant IH_VERSION
    Von moonbooter im Forum Installation / Update
    Antworten: 2
    Letzter Beitrag: 20.02.2020, 10:48
  2. (Zen-Cart 1.5.6) PHP 7.3 - Use of undefined constant
    Von harryg im Forum Generelle Fragen
    Antworten: 2
    Letzter Beitrag: 19.02.2020, 20:19
  3. (Zen-Cart 1.5.6) Use of undefined constant customer_id
    Von bumerang24 im Forum Google Analytics
    Antworten: 1
    Letzter Beitrag: 26.09.2019, 09:49
  4. (Zen-Cart 1.5.6) Use of undefined constant OSH_EMAIL_TEXT_COWOA_URL
    Von bumerang24 im Forum Bestellen ohne Kundenkonto - COWOA
    Antworten: 2
    Letzter Beitrag: 20.09.2019, 14:09
  5. (Zen-Cart 1.5.6) Use of undefined constant IH_VERSION
    Von bumerang24 im Forum Image Handler
    Antworten: 4
    Letzter Beitrag: 20.09.2019, 08:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.
Die amerikanische Zen-Cart Version berücksichtigt viele rechtliche Erfordernisse nicht, denen ein Onlineshop im deutschsprachigen Raum unterworfen ist. Daher wurde die deutsche Zen-Cart Version nicht nur bloß ins Deutsche übersetzt, sondern auch funktional auf die Anforderungen, die an Onlineshops in Deutschland, Österreich und der Schweiz gestellt werden, angepasst.

Die amerikanische Version ist extrem abgespeckt und stellt weiterführende Funktionalitäten durch zusätzliche Module bereit, die erst mühsam manuell installiert werden müssen. Zahlreiche häufig genutzte Erweiterungen und eigene Entwicklungen sind in der deutschen Zen Cart Version bereits vorinstalliert.
Die deutsche Zen-Cart Version bietet außerdem einen völlig multilingualen Adminbereich. Weitere für die deutsche Zen Cart Version angepasste Erweiterungen stehen in unserem Downloadbereich zur Verfügung.

Die deutsche Zen Cart Version wird seit 16 Jahren von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.6f deutsch
vom 20.06.2021
[Download]

unterstützen
Unterstütze die Weiterentwicklung der deutschen Zen Cart Version mit einer Spende!

Spende für die Weiterentwicklung der deutschen Zen Cart Version