Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 19

Thema: Installation beginnt immer wieder von neuem

  1. #1
    Padawan Anwärter Avatar von harrison131154
    Registriert seit
    15.11.2006
    Beiträge
    9
    Themen
    2
    DANKE
    0
    Erhaltene Danke: 0

    Standard Installation beginnt immer wieder von neuem

    ich will zc 1.3.5 (oder auch 1.3.6) auf einem strato-server installieren, jedoch wird die installation nicht abgeschlossen, sie fängt immer wieder von vorne an, ohne dass zB, die datenbank parameter eingegeben wurden. zu sehen ist das problem auf www.hobby-paradise.eu
    Wer kann mir helfen?

    eventuell auf mich unter info@rolandhartl.de informieren, danke

    mfg
    harrison131154

  2. #2
    Jedi-Ritter Avatar von MaleBorg
    Registriert seit
    17.05.2006
    Beiträge
    3.043
    Themen
    30
    DANKE
    5
    Erhaltene Danke: 82

    Standard

    Tut mir leid, auf der Seite kann ich leider keinen Fehler sehen, da beim Klick auf EINGANG nur eine 404 Fehlerseite erscheint.

    Erscheint denn so gar keine Fehlermeldung bei der Installation ?

    Gruß
    MaleBorg

  3. #3
    Padawan Stufe II Avatar von pzet
    Registriert seit
    22.12.2004
    Ort
    Bangkok
    Beiträge
    133
    Themen
    9
    DANKE
    0
    erhaltene Danke

    Standard

    Hallo,

    kriege auch nur eine 404-Fehler Seite.
    Was mit aufgefallen ist, daß der Pfad 2 x den Domainname anzeigt!
    Prüfe doch mal Deine Pfade.

    Gruß

  4. #4
    Padawan Anwärter Avatar von harrison131154
    Registriert seit
    15.11.2006
    Beiträge
    9
    Themen
    2
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Hi Maleborg,
    dieser eingang ist noch gar nicht gesetzt, weil ja die installation nicht abgeschlossen ist, ergo: sind auch noch nicht die umbenennungen erfolgt. wenn du also ganz normal /catalog/ eingibst, dann fängst du noch mal mit der installation an. Ich habe mal woanders (auch stratoserver ne version 1.2.3 installiert und komme dort bei der installation bis zur eingabe vom pHpBB an.
    also nochmal: meines wissens muss die installation je auch die datenbänke ansprechen. ich kenne zb das os-commerce milestone 2.2, da ist es auch so, ich WILL aber unbedingt zen-cart installieren.....

    Hilfe, bitte, HILFE !!!!

    mfg
    roland hartl

  5. #5
    Padawan Anwärter Avatar von harrison131154
    Registriert seit
    15.11.2006
    Beiträge
    9
    Themen
    2
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Hi pzet,
    dieser eingang ist noch gar nicht gesetzt, weil ja die installation nicht abgeschlossen ist, ergo: sind auch noch nicht die umbenennungen erfolgt. wenn du also ganz normal /catalog/ eingibst, dann fängst du noch mal mit der installation an. Ich habe mal woanders (auch stratoserver ne version 1.2.3 installiert und komme dort bei der installation bis zur eingabe vom pHpBB an.
    also nochmal: meines wissens muss die installation je auch die datenbänke ansprechen. ich kenne zb das os-commerce milestone 2.2, da ist es auch so, ich WILL aber unbedingt zen-cart installieren.....

    Hilfe, bitte, HILFE !!!!

    mfg
    roland hartl

  6. #6
    Padawan Stufe II Avatar von pzet
    Registriert seit
    22.12.2004
    Ort
    Bangkok
    Beiträge
    133
    Themen
    9
    DANKE
    0
    erhaltene Danke

    Standard

    Hallo,

    ich habe jetzt mal die Seite aufgerufen, die Installations Routine startet bis zu dem "system setup" was die Pfade zu der Installation festlegt.

    Nochmals - bitte Pfade überprüfen, notfalls alles nochmals hochladen und neu installieren.

    Falls es trotzdem nicht klappt würde ich mal Strato kontaktieren und um deren Unterstützung/Erklärung bitten.
    Es wurde hier im Forum wiederholt von Problemen mit Strato (und 1&1) berichtet.

    Gruß

  7. #7
    Obi-RAI Kenobi Avatar von hugo13
    Registriert seit
    23.04.2004
    Beiträge
    1.267
    Themen
    9
    DANKE
    2
    Erhaltene Danke: 19

    Standard

    ich denke es liegt an der php-version; siehe: http://www.zen-cart.com/forum/showthread.php?t=7890
    & ich denke, der hoster darf eine fast 2 jahre alte php-version durchaus updaten

    for fun: http://www.hobby-paradise.eu/catalog...se_phpbb=false == deine install-routine
    salute
    rai

    FAQ | SHOP

  8. #8
    Padawan Anwärter Avatar von harrison131154
    Registriert seit
    15.11.2006
    Beiträge
    9
    Themen
    2
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    danke hugo13,
    zumindest weiss ich jetzt dass es wohl an der php-version liegt, mein problem ist, dass der strato server nicht von straot verwaltet wirde, und ich mich in linux nicht soooo gut auskenne um das update problemlos durchziehen kann. es sind andere domains auf dem server, die eventuell dann in den php-scripten nicht mehr richtig laufen.

    kann man das problem um gehen? noch was, deinen link zur installationsroutine hab ich mal angeklickt und versucht die daten einzugeben, ich bekomme jedoch den fehler dass es in der configure.php ein schreibfehler gibt, obwohl ich die dateien dist-configure.php umbenannt und auch chmod 777 gesetzt habe....

    mfg
    harrison131154

  9. #9
    Obi-RAI Kenobi Avatar von hugo13
    Registriert seit
    23.04.2004
    Beiträge
    1.267
    Themen
    9
    DANKE
    2
    Erhaltene Danke: 19

    Standard CONF

    hi

    admin/includes/configure.php

    Code:
    <?php
    //
    /**
     *
     * @package Configuration Settings
     * @copyright Copyright 2003-2006 Zen Cart Development Team
     * @copyright Portions Copyright 2003 osCommerce
     * @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
     */
    
    
    /*************** NOTE: This file is similar, but DIFFERENT from the "store" version of configure.php. ***********/
    /***************       The 2 files should be kept separate and not used to overwrite each other.      ***********/
    
    // Define the webserver and path parameters
      // Main webserver: eg, http://localhost - should not be empty for productive servers
      // HTTP_SERVER is your Main webserver: eg, http://www.yourdomain.com
      // HTTPS_SERVER is your Secure webserver: eg, https://www.yourdomain.com
      // HTTP_CATALOG_SERVER is your Main webserver: eg, http://www.yourdomain.com
      // HTTPS_CATALOG_SERVER is your Secure webserver: eg, https://www.yourdomain.com
      /* 
       * URLs for your site will be built via:  
       *     HTTP_SERVER plus DIR_WS_ADMIN or
       *     HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or 
       *     HTTP_SERVER plus DIR_WS_CATALOG or 
       *     HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG
       * ...depending on your system configuration settings
       */
      define('HTTP_SERVER', 'http://www.hobby-paradise.eu/catalog');
      define('HTTPS_SERVER', 'https://all.ar-pub.com');
      define('HTTP_CATALOG_SERVER', 'http://www.hobby-paradise.eu/catalog');
      define('HTTPS_CATALOG_SERVER', 'https://www.hobby-paradise.eu/catalog');
    
      // Use secure webserver for catalog module and/or admin areas?
      define('ENABLE_SSL_CATALOG', 'false');
      define('ENABLE_SSL_ADMIN', 'false');
    
    // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
    // * DIR_WS_* = Webserver directories (virtual/URL)
      // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
      define('DIR_WS_ADMIN', '/catalog/admin/');
      define('DIR_WS_CATALOG', '/catalog/');
      define('DIR_WS_HTTPS_ADMIN', '/catalog/admin/');
      define('DIR_WS_HTTPS_CATALOG', '/catalog/');
    
      define('DIR_WS_IMAGES', 'images/');
      define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
      define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/');
      define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/');
      define('DIR_WS_INCLUDES', 'includes/');
      define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
      define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
      define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
      define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
      define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
      define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/');
    
    // * DIR_FS_* = Filesystem directories (local/physical)
      //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
      define('DIR_FS_ADMIN', '/home/h/hobby-paradise.eu/public_html/catalog/admin/');
      define('DIR_FS_CATALOG', '/home/h/hobby-paradise.eu/public_html/catalog/');
    
      define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
      define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
      define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
      define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/');
      define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
      define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
      define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
    
    // define our database connection
      define('DB_TYPE', 'mysql');
      define('DB_PREFIX', '');
      define('DB_SERVER', 'localhost');
      define('DB_SERVER_USERNAME', 'MYSQL_USER');
      define('DB_SERVER_PASSWORD', 'PW');
      define('DB_DATABASE', 'DB');
      define('USE_PCONNECT', 'true'); // use persistent connections?
      define('STORE_SESSIONS', 'db'); // use 'db' for best support, or '' for file-based storage
    
      // The next 2 "defines" are for SQL cache support.
      // For SQL_CACHE_METHOD, you can select from:  none, database, or file
      // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache 
      // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder
      // ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash  
      define('SQL_CACHE_METHOD', 'file'); 
      define('DIR_FS_SQL_CACHE', '/home/h/hobby-paradise.eu/public_html/catalog/cache/');
    ?>
    die datenbankgeschichten musst du entsprechend anpassen

    für includes/configure.php nimmst du obiges file & das entspr. disti-file als vorlage
    salute
    rai

    FAQ | SHOP

  10. #10
    Jedi-Ritter Avatar von MaleBorg
    Registriert seit
    17.05.2006
    Beiträge
    3.043
    Themen
    30
    DANKE
    5
    Erhaltene Danke: 82

    Standard

    Also PHP 4.3.3 sollte nicht das Problem sein, da auf meiner Testumgebung schon ältere Versionen liefen und Zencart da nie gemeckert hat.

    Allerdings macht mich die PHP API Modus = CGI Sache stutzig.

    Gruß
    MaleBorg

Seite 1 von 2 12 LetzteLetzte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1188 vom 02.12.2016
[Download]