Ergebnis 1 bis 9 von 9

Thema: [solved] Fehler in Erweiterte Suche

  1. #1
    Padawan Anwärter Avatar von vscharfe
    Registriert seit
    29.09.2006
    Beiträge
    21
    Themen
    4
    DANKE
    0
    Erhaltene Danke: 0

    Standard [solved] Fehler in Erweiterte Suche

    Hallo,
    beim Aufrufen der Erweiterten Suche "shop/index.php?main_page=advanced_search" wird oben rechts ein Link "Hilfe [?]" angezeigt. Dieses Popup öffnet sich nicht. Es wird ein Fehler erzeugt. Ist aber nicht nur bei mir so, ich habe einige andere Zen-Cart Shops besucht, die den gleichen Fehler haben. So auch hier:

    http://www.muenzenhandlung.at/shop/i...dvanced_search

    Im IE wird gemeldet: Fehler in Zeile 50, Zeichen 43, ';' wird erwartet, Code 0 - ich weis aber nicht wo ich hier suchen muss, weil die Seite aus mehrern Elementen zusammengefügt wird.

    Ich verwende ZC 1.3.5de

    Wäre für eine Antwort sehr dankbar
    Gruß

  2. #2
    Padawan Anwärter Avatar von vscharfe
    Registriert seit
    29.09.2006
    Beiträge
    21
    Themen
    4
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Hat denn keinen einen Tipp für mich? Ich finde im Forum dazu leider keine Antwort, obwohl der Fehler bei einigen ZC-Nutzern identisch ist.
    Gruß

  3. #3
    Jedi-Ritter Avatar von MaleBorg
    Registriert seit
    17.05.2006
    Beiträge
    3.043
    Themen
    30
    DANKE
    5
    Erhaltene Danke: 82

    Standard

    Kleine Ursache große Wirkung!

    Bei der deutschen Übersetzung sind in die Fehlermeldungen Anführungszeichen eingebaut worden. Das mag scheinbar der PHP Code nicht.

    Zur Fehlerbehebung gehst du bitte in die Datei includes/languages/german/advanced_search_php und nimmst bei den Texten am Ende der Datei die " raus.

    Das sollte dann so Ausschauen
    define('ERROR_TO_DATE_LESS_THAN_FROM_DATE','Eintra g bis muss später als Eintrag vom sein.');
    define('ERROR_PRICE_FROM_MUST_BE_NUM', 'Preis von muss eine Zahl sein.');
    define('ERROR_PRICE_TO_MUST_BE_NUM', 'Preis bis muss eine Zahl sein.');
    define('ERROR_PRICE_TO_LESS_THAN_PRICE_FROM','Prei s bis muss größer sein als Preis von.');
    define('ERROR_INVALID_KEYWORDS','Falsche Suchwörter.');

    Ich bitte drum, das dann gleich in der deutschen Version 1.3.6 zu korrigieren.

    Gruß
    MaleBorg

  4. #4
    Padawan Anwärter Avatar von vscharfe
    Registriert seit
    29.09.2006
    Beiträge
    21
    Themen
    4
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Danke MaleBorg,
    jetzt klappt es.

  5. #5
    Padawan Stufe V Avatar von marino01
    Registriert seit
    02.12.2006
    Beiträge
    530
    Themen
    23
    DANKE
    0
    Erhaltene Danke: 0

    Standard

    stimmt php und ausführungszeichen vertragen sich nicht - da ausführugszeichen als zwei ' interpretiert werden - was automatisch zu einer scriptfehler-meldung führt.. es gibt die möglichkeit ausführungszeichen als solchen in einer lang-datei zu verwenden, allerdings ist die so aufwendig und kompliziert ( zb durch einfügen einer textarea) das das niemand macht

  6. #6
    Padawan Stufe III Avatar von Subhash
    Registriert seit
    17.12.2006
    Beiträge
    237
    Themen
    47
    DANKE
    10
    Erhaltene Danke: 4

    Standard

    Na ja, so geht's auch einfach mit Anführungszeichen:

    Code:
    define('ERROR_TO_DATE_LESS_THAN_FROM_DATE','„Eintrag bis” muss später als Eintrag „vom” sein.');
    define('ERROR_PRICE_FROM_MUST_BE_NUM', '„Preis von” muss eine Zahl sein.');
    define('ERROR_PRICE_TO_MUST_BE_NUM', '„Preis bis” muss eine Zahl sein.');
    define('ERROR_PRICE_TO_LESS_THAN_PRICE_FROM','„Preis bis” muss größer sein als „Preis von”.');
    define('ERROR_INVALID_KEYWORDS','Falsche Suchwörter.');
    Getestet mit Safari 2.0
    IE 6
    Firefox 2 (auf Mac und Windows)

    Schlimmer als diese Umlautgeschichte scheint mir zu sein, dass die erweiterte Suche im neuen IE 7 anscheinend gar nicht klappt, wenn man falsche Eingaben macht.

  7. #7
    Padawan Stufe III Avatar von JeffClay
    Registriert seit
    04.12.2007
    Beiträge
    176
    Themen
    21
    DANKE
    0
    Erhaltene Danke: 0

    Standard

    mir ist dieser fehler gerade in der deutschen 138a hier aus dem downloadbereich begegnet. die lösung ist die selbe.

    gruß und thx Jeff
    gruß Jeff Clay

    I AM ROOT.
    If you see me laughing, you'd better have a backup!

    Intel: "Was machen wir heute Abend?"
    Microsoft: "Das, was wir jeden Abend machen: Versuchen die Weltherrschaft an uns zu reissen!"

  8. #8
    Jedi-Ritter Avatar von MaleBorg
    Registriert seit
    17.05.2006
    Beiträge
    3.043
    Themen
    30
    DANKE
    5
    Erhaltene Danke: 82

    Standard

    Ok Fehler in der Datei behoben und in die SVN Datei geschoben. Sollte damit in der Zukunft nicht mehr auftreten.

    Gruß
    MaleBorg

  9. #9
    Padawan Stufe III Avatar von JeffClay
    Registriert seit
    04.12.2007
    Beiträge
    176
    Themen
    21
    DANKE
    0
    Erhaltene Danke: 0

    Standard

    thx

    gruß Jeff
    gruß Jeff Clay

    I AM ROOT.
    If you see me laughing, you'd better have a backup!

    Intel: "Was machen wir heute Abend?"
    Microsoft: "Das, was wir jeden Abend machen: Versuchen die Weltherrschaft an uns zu reissen!"

Ähnliche Themen

  1. Erweiterte Suche
    Von Gandalfine im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 10
    Letzter Beitrag: 11.08.2011, 12:50
  2. [solved] Bestell - Fehler Behoben?
    Von afrobay im Forum Zen Cart Bug Report
    Antworten: 5
    Letzter Beitrag: 04.12.2008, 11:09
  3. Fehler bei Suche
    Von rime92 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 2
    Letzter Beitrag: 05.02.2008, 21:33
  4. Erweiterte Suche anpassen
    Von arkat im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 2
    Letzter Beitrag: 26.02.2007, 06:12
  5. Fehler bei Datumsformat in der erweiterten Suche
    Von web28 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 0
    Letzter Beitrag: 04.04.2006, 17:18

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1184 vom 01.09.2016
[Download]