Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Nach Update werden Artikel nicht mehr angezeigt

  1. #1
    Padawan Anwärter Avatar von sabaton222
    Registriert seit
    11.10.2008
    Beiträge
    6
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0

    Standard Nach Update werden Artikel nicht mehr angezeigt

    Guten Morgen,

    ich habe heute Nacht ein Update von Version 1.2.4.1 zu 1.3.8a gemacht und habe nun das Problem, dass alle Artikel über das Kategorienmenu nicht mehr angezeigt werden. Die Kategorien können zwar aufgerufen werden, jedoch werden keine Artikel angezeigt.

    Hier ein paar Infos zum System:

    Apache Server mit PHP4.4.8 und MySQL 5.0.32
    SAFE_MOD ist on

    Über die Sonderangebote-Box kann ich die vorhandenen Sonderangebote aufrufen, jedoch über die Kategorien nicht. Hier mal der Link zum Shop: http://www.pharma-liebermann.de/shop

    Bei Klick auf "Ähnliche Artikel" erhalte ich außerdem die folgende Fehlermeldung:

    Code:
    1054 Unknown column 'p.products_id' in 'on clause'
    in:
    [select count(*) as total from zen_products p left join zen_manufacturers m on (p.manufacturers_id = m.manufacturers_id), zen_products_description pd left join zen_featured f on p.products_id = f.products_id where p.products_status = '1' and p.products_id = f.products_id and f.status = '1' and p.products_id = pd.products_id and pd.language_id = '43']

  2. #2
    Padawan Stufe VIII Avatar von Lissy73
    Registriert seit
    27.09.2006
    Ort
    Rheinland-Pfalz
    Beiträge
    996
    Themen
    95
    DANKE
    0
    Erhaltene Danke: 2

    Standard

    Hallo sabaton222,

    sind denn deine Artikel im Admin alle verfügbar? Sind diese evtl. alle deaktiviert?

    Von Version 1.2.4.1 auf 1.3.8 ist natürlich ein riesen Schritt, und soviel ich weiß wurden die Älteren Versionen auf einer Art Tabellen funktion aufgebaut, daher ist es auch ganz schwer alte Module für die neue Version umzuschreiben!

    Die Fehlermeldung sieht für mich so aus als würde hier ein Prefix Fehler vorliegen und auch die Sprachdatei denn die "43" steht ja für die Deutsche Sprachdatei!

    100 % sicher bin ich mir aber nicht!

    Fakt ist auf alle Fälle, dass Version 1.3.8 nicht mit den Artikelstamm von Version 1.2.4.1 zurecht kommt.

    Vielleicht solltest du einen Testartikel anlegen, diesen exportieren und dann dein Artikelstamm von der alten Version dort hinein kopieren und dann wieder neu importieren!

    Gruß
    Lissy
    Gruß
    Lissy

    *****************************

    ZenCart Version 1.3.7 sowie ZC 1.3.8

    Apache/2.0.54 (Debian GNU/Linux) mod_ssl/2.0.54 OpenSSL/0.9.7e

  3. #3
    Padawan Anwärter Avatar von sabaton222
    Registriert seit
    11.10.2008
    Beiträge
    6
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Vielen Dank für Deine schnelle Antwort.

    Die Artikel sind alle aktiviert und ich habe testweise eine neue Kategorie inkl. Artikel von Hand angelegt. Doch auch da wird leider nichts angezeigt im Frontend.

  4. #4
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.078
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Lade bitte mal die includes/modules/meta_tags.php vom Server, öffne sie und poste, was dort in ca. Zeile 9 steht:
    Code:
    @version $Id: meta_tags.php 6863 2007-08-27 16:06:25Z drbyte $
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  5. #5
    Padawan Anwärter Avatar von sabaton222
    Registriert seit
    11.10.2008
    Beiträge
    6
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Code:
     * @version $Id: meta_tags.php 6863 2007-08-27 16:06:25Z drbyte $
    Scheint wohl identisch zu sein mit Deinem Post

  6. #6
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.078
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Der 1.2.4.1 Shop vorher, lief der problemlos mit MySQL5?
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  7. #7
    Padawan Anwärter Avatar von sabaton222
    Registriert seit
    11.10.2008
    Beiträge
    6
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Nein, es erschien beim Versuch, neue Artikel einzustellen immer folgende Fehlermeldung: 1054 Unknown column 'p.products_id' in 'on clause'

    Nachdem ich mich diesbezüglich im Netz umgesehen hab, schien das an der MySQL-Version zu liegen. Es wurde geraten, die aktuelle 1.3.8a Version zur Fehlerbehebung zu installieren.

    Ansonsten lief der Shop einwandfrei.

  8. #8
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.078
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Was mich etwas wundert ist die Kombination PHP4.4.8 und MySQL 5.0.32. Kannst Du bei diesem Provider auch PHP5 nutzen?
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  9. #9
    Padawan Anwärter Avatar von sabaton222
    Registriert seit
    11.10.2008
    Beiträge
    6
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Nein, leider nicht. Meinst Du, dass es an der Kobination PHP/MySQL liegen könnte?

  10. #10
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.078
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Was ist das für ein Provider?

    PHP5 sollte Standard sein!
    Für einige Dinge im Shop ist PHP5 bereits jetzt Voraussetzung, künftige Versionen werden das ohnehin generell voraussetzen.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

Seite 1 von 2 12 LetzteLetzte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1188 vom 02.12.2016
[Download]