Ergebnis 1 bis 6 von 6

Thema: Fehler in PDF Rechnung 3

  1. #1
    Padawan Anwärter Avatar von Gremlin0001
    Registriert seit
    08.07.2009
    Beiträge
    10
    Themen
    5
    DANKE
    0
    Erhaltene Danke: 0

    Ausrufezeichen Fehler in PDF Rechnung 3

    Hallo erstmal an alle hier. Bin relativ neu und habe wenig Ahnung von Programmierung und dergleichen. Setze mich allerdings gerne mit dem Thema auseinander und versuche mich in Foren und anderen "HilfeSeiten" einzulesen.

    Ich habe mich vor kurzen für ZenCart entschieden und bin mit diesem ShopSystem auch relativ zufrieden.

    Um meinen Shop von anderen abzuheben (und ich denke, dass möchte jeder) und die Arbeit hiermit so systematisch wie möglich zu gestalten bin ich hier auch auf der Suche nach neuen Modulen, die den vereinbarten Ablauf realisieren.

    Heute Nacht habe ich mir das PDF Rechnungsmodul 3 heruntergeladen und installiert. Dummerweise habe ich (allen Warnungen zum Trotz) das Modul in einen Live-Shop installiert. Wenn ich nun in im Adminbereich bin und dort sollen ja neben den Bestellungen nun die Auswahlbuddons erscheinen, so steht dort bei mir folgende Fehlermeldung:

    Code:
    Fatal error: Call to undefined function zen_get_orders_comments() in /srv/www/htdocs/web322/html/shop/admin/orders.php on line 817

    Ich bitte um Hilfe. Kann mir einer sagen wie ich den Fehler beheben kann. OHNE, den Shop neu zu installieren? Habe mich genau an die Anweisungen gehalten. Ajax in den Ajaxordner, PHP in das Shopverzeichnis und include in das include verzeichnis. es kamen auch die beschriebenen Meldungen, das orders.php bereits vorhanden sei und überschrieben wird, dies habe ich auch , wie vorgeschrieben, zugelassen. Allerdings stand in der Installationsnleitung das admin/orders.php überschrieben wird. dies hat er auch beim kopieren getan. Allerdings auch 3-6 weitere Dateien.

    Meine ZenCart Version und Serverinfos:

    Zen Cart 1.3.7 Deutsch


    Serverinformation Server Host: www.lcs-electronics.com (88.198.63.185) Datenbank Host: localhost (127.0.0.1) Server Betriebssystem: Linux lucem 2.6.25.1-sev-854-3-1g #1 SMP Sun May 4 18:30:15 CEST 2008 x86_64 Datenbank: MySQL 5.0.51a-0.dotdeb.1-log Server Datum: 12.07.2009 14:33:40 Datenbank Datum: 12.07.2009 14:33:40 Server Up Time:
    PHP Version: 5.2.6-0.dotdeb.1 (Zend: 2.2.0)
    HTTP Server: Apache/2.2.3 (Debian) PHP/5.2.6-0.dotdeb.1 with Suhosin-Patch mod_ssl/2.2.3 OpenSSL/0.9.8c mod_perl/2.0.2 Perl/v5.8.8


    Achso: safe_mode ist ON

    Vielen Dank für Eure Hilfe
    Geändert von Gremlin0001 (12.07.2009 um 13:45 Uhr) Grund: Zusatz

  2. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.055
    Themen
    81
    DANKE
    3
    Erhaltene Danke: 954

    Standard

    Achte bitte immer darauf, für welche Zen-Cart Version ein Modul geeignet ist. Die pdf Rechnung 3 ist nur für Zen-Cart 1.3.8!

    Schau welche Dateien überschrieben wurden und stelle wieder Deine alten aus Deinem Backup her.
    Die zusätzlich angelegten Dateien vom Server löschen.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #3
    Padawan Stufe IV Avatar von rsagb
    Registriert seit
    08.03.2007
    Beiträge
    328
    Themen
    31
    DANKE
    8
    Erhaltene Danke: 3

    Standard

    zuerst: schau die die betreffende Zeile an die in der Fehlermeldung steht.
    Manchmal fehlt da abschließendes ?> oder irgend ein anderes HTML-Teil oder
    die Datei ist nicht utf-8 kodiert.

    falls es das nicht sein sollte:

    1.) kopiere die original orders.php aus dem shop v1.3.8. in das entsprechende Verzeichnis
    anschließend sollte zumindest der admin bereich wieder funktionieren

    2.) Vergleiche die original orders.php mit der aus pdfrechnung und ziehe nur die
    Änderungen der PDF-Rechnung in deine Original orders-php nach.

    Tool: Winmerge oder ähnliches
    Grüße
    rsagb

  4. #4
    Padawan Anwärter Avatar von Gremlin0001
    Registriert seit
    08.07.2009
    Beiträge
    10
    Themen
    5
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard Na doll

    SICHERUNG

    Na, das heißt dann wohl, noch mal alles von vorne. habe noch keine Sicherung angelegt

    Kann man das i-wie ändern oder den Fehler nicht einfach korrigieren ?

    oder kann ich die Deutsche Version nicht einfach auf 1.3.8 updaten so dass sie Deutsch bleibt und PDF dann funzt ?

  5. #5
    Padawan Anwärter Avatar von Gremlin0001
    Registriert seit
    08.07.2009
    Beiträge
    10
    Themen
    5
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    ja, das hört sich alles ganz nett an. Aber mein erstes Problem liegt bereits darin, dass wenn ich die orders.php im editor starte, dann ergibt das einen ellenlangen Text ohne Line-Bezeichnung.

    und wenn ich es dann gefunden habe, dann stehe ich vor dem Text wie ein Esel vorm offenen Scheunentor und finde den Weg nicht hinein.

    Ich dachte auch, ich habe mir die aktuellste Version herundergeladen. Jetzt habe ich gerade gesehen, das es da wohl die 1.3.8a in Deutsch gibt. wenn ich im Shop auf Version prüfen gehe, dann sagt er mir, das ich aktuellste Version habe.


    Hmmmm. Ich werde wohl alles löschen und die neue Version installieren müssen. Wohl oder übel.


    Dennoch Danke für Eure liebe Hilfe.

    LG Gremlin

  6. #6
    Padawan Stufe IV Avatar von rsagb
    Registriert seit
    08.03.2007
    Beiträge
    328
    Themen
    31
    DANKE
    8
    Erhaltene Danke: 3

    Standard

    du solltest einen editor verwenden der utf-8 speicher kann z.B. Ultra-Edit.
    beim öffnen der Dateien keinesfalls in DOS-Mode oder ähnliches konvertieren was in der Meldung angezeigt wird ! ! !

    und ja - sicherung !

    Ich mach das vor jeder Änderung ! Spart einem ziemlich viel Arbeit.....

    Auch wenn ich einen neuen Shop aufsetze z.b. bei Upgrade, wird nach jeder Modul-Installation die letzte funktionierende Version weggesichert incl. passender DB.
    Der Souce-Code wandert bei mir in Subversion zur Versionsverwaltung. Sicher ist sicher.
    Grüße
    rsagb

Ähnliche Themen

  1. PDF Rechnung funktioniert nich im Firefox
    Von elpego im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 7
    Letzter Beitrag: 11.01.2009, 11:24
  2. PDF RECHNUNG FEHLERMELDUNG
    Von jensk1981 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 17
    Letzter Beitrag: 28.03.2007, 00:11
  3. Konfiguration PDF Rechnung v. 0.5
    Von ingo10 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 35
    Letzter Beitrag: 22.02.2007, 12:17
  4. PDF Rechnung SQL Fehler
    Von e1845 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 17
    Letzter Beitrag: 28.06.2006, 13:08
  5. Fehler PDF Rechnung v0.4d
    Von molle im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 16
    Letzter Beitrag: 13.01.2005, 08:15

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1184 vom 01.09.2016
[Download]