Es ist PHP5 erforderlich.
Mit PHP4 wird die Fehlermeldung Fatal error: Call to undefined function: htmlspecialchars_decode() kommen.
PHP4 wird bereits seit Mitte 2008 nicht mehr von php.net supportet!
Bei vielen Providern ist PHP5 schon lange vorhanden und kann mittels .htaccess aktiviert werden. Sollte PHP5 nicht vorhanden sein, an den Provider wenden, damit der ein Update macht. Generell sind zum Betrieb von Zen-Cart 1.3.8 dringend PHP 5.2.x und MySQL 5.x empfohlen.