Hallo zusammen,

erstmal ein großes Lob für dieses Forum. Wir betreiben seit ca. 2 Jahren mehrere Zen!Cart-Shops und haben hier bei Problemen immer Hilfe gefunden. Vielen Dank dafür.

Jetzt tritt aber seit ca. 2-3 Wochen ab und zu ein Problem auf, zu dem wir nach intensiver Suche im Forum nichts gefunden haben.

Bei einigen Kunden stehen wir vor folgendem Phänomen. Ein Kunde hat die Artikel, die er bestellen möchte, in den Warenkorb gelegt und klickt sich durch die Bestellung. Alles klappt wie gewohnt. Wenn er die Bestellung dann aber abschließen möchte wird er einfach auf die Startseite umgeleitet, der Warenkorb bleibt gespeichert, aber es geht keine Bestellung ein. Im Shop nicht, Emails werden auch nicht versandt.

Interessant ist, wenn man sich auf einem anderen Rechner mit den Daten des Kunden im Shop anmeldet und die Bestellung mit dem gespeicherten Warenkorb durchführt, kommt es zu dem selben Fehler. Sobald man aber etwas in das Kommentarfeld schreibt, kann man die Bestellung normal zuende führen.

Ich hatte mir jetzt überlegt, standartmäßig ein Leerzeichen oder einige Punkte in das Kommentarfeld zu schreiben um den Fehler zu umgehen, aber eine vernünftige Lösung ist das nicht.

Kennt jemand hier das Problem und hat einen Rat für uns?

Vielen Dank.

Grüße, Tobias.

P.S. Vielleicht noch eine Zusatzinfo. Wir sind bei 1und1. Bis vor kurzen liefen die Server dort mit PHP 4.x. Kürzlich hat 1und1 aber auf PHP 5.2 umgestellt. Ich kann mir nicht vorstellen, das unser Problem daher kommt, aber vielleicht ist es wichtig.