Ergebnis 1 bis 1 von 1

Thema: PHP 5.3 Patch für Zen-Cart 1.3.8

  1. #1
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.093
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 962

    Ausrufezeichen PHP 5.3 Patch für Zen-Cart 1.3.8

    PHP 5.3 Patch für Zen Cart 1.3.8

    Manche Provider haben bereits auf die PHP Version 5.3 umgestellt. Zen-Cart 1.3.8 funktioniert unter PHP 5.3 nur mit dem angehängten seit 09.11.2009 verfügbaren Patch.

    Hinweis:
    Dieser Patch unterdrückt nur die wichtigsten Fehler, die beim Betrieb von Zen-Cart 1.3.8 unter PHP 5.3 ausgegeben werden.
    Er sollte nur als Übergang gesehen werden, bevor auf mit PHP 5.3 kompatible Versionen wie 1.3.9 oder 1.5 upgedated wird.
    Auch mit diesem Patch ist Zen-Cart 1.3.8 weiterhin nicht wirklich PHP 5.3 kompatibel und bleibt ein veraltetes unsicheres System.

    Dieser Patch wird nur benötigt, wenn Sie Zen-Cart 1.3.8 auf einem Server einsetzen wollen, auf dem PHP 5.3 läuft
    Wenn Sie PHP 5.2x und älter verwenden, müssen Sie diesen Patch nicht einspielen!
    (Der Patch ist aber abwärtskompatibel, Zen-Cart wird mit diesem Patch also auch mit PHP 5.2.x und älter funktionieren)

    Dieser Patch ist NICHT kompatibel mit älteren Zen-Cart Version und nur für 1.3.8 geeignet!


    INSTALLATIONSANLEITUNG:

    1.
    Entpacken Sie die zc138a-php53patch.zip Datei. Achten Sie darauf, dass Ihr zip-Programm (z.B. WinZip, WinRAR) beim Entpacken die Ordnerstruktur beibehält.

    2.
    Sie erhalten dann folgende 13 Dateien in folgender Struktur:

    /admin/includes/application_top.php
    /admin/includes/classes/phplot.php
    /admin/includes/functions/general.php
    /admin/includes/functions/html_output.php
    /admin/includes/header.php
    /admin/includes/modules/orders_download.php
    /admin/orders.php
    /includes/application_top.php
    /includes/functions/functions_general.php
    /includes/functions/html_output.php
    /includes/modules/payment/paypal/paypal_functions.php
    /zc_install/includes/application_top.php
    /zc_install/includes/classes/installer.php

    3.
    Wenn Sie einen bestehenden Zen-Cart 1.3.8 Shop PHP 5.3 kompatibel machen wollen, laden Sie die Datei /zc_install/includes/application_top.php und /zc_install/includes/classes/installer NICHT hoch. Diese Datei wird nur benötigt, wenn Sie Zen-Cart in einer PHP 5.3 Umgebung neu installieren wollen.

    4.
    Falls Sie die Dateien in Ihrem Livesystem vorher nie geändert haben, können Sie nun einfach die Patch Dateien hochladen und ihre bestehenden Dateien damit überschreiben.
    Sollten Sie an diesen Dateien bereits einmal Änderungen vorgenommen haben, vergleichen Sie den Inhalt mit einem geeigneten Programm (WinMerge oder Beyond Compare) und führen die Änderungen manuell durch.
    Ihr admin Verzeichnis haben Sie ja hoffentlich bereits einmal umbenannt, achten Sie also darauf, dass die Dateien im Ordner admin in Ihr umbenanntes admin Verzeichnis gehören.
    Achten Sie ebenfalls darauf, die richtigen Dateien zu bearbeiten. Es gibt in Zen-Cart mehrere Dateien namens application_top.php oder html_output.php. Es geht hier nur um die 11 Dateien, in der angegebenen Struktur.
    Geändert von webchills (27.03.2012 um 16:06 Uhr)
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

Ähnliche Themen

  1. [solved] PHP 5.3 patch
    Von eentje im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 3
    Letzter Beitrag: 27.03.2010, 08:28
  2. zen cart mit php 5
    Von kostonstyle im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 23
    Letzter Beitrag: 19.04.2007, 11:12
  3. Kein Zugang zum Admin-Bereich nach Install von 1.3.6 DE
    Von taifun89343 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 22
    Letzter Beitrag: 12.01.2007, 21:11
  4. Zen Cart v1.3.5 XSS PATCH
    Von hemzet im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 1
    Letzter Beitrag: 05.10.2006, 12:05
  5. Zen Cart Beta 1.1.3d deutsch inkl. Patch 2
    Von cyaneo im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 1
    Letzter Beitrag: 21.04.2004, 19:36

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1188 vom 02.12.2016
[Download]