Ergebnis 1 bis 6 von 6

Thema: Anpassung wegen Abschaltung von old-passwords

  1. #1
    Padawan Stufe I Avatar von schuko80
    Registriert seit
    23.11.2007
    Beiträge
    27
    Themen
    9
    DANKE
    0
    Erhaltene Danke: 0

    Standard Anpassung wegen Abschaltung von old-passwords

    Heute teilte mir mein Provider (All-inkl) mit, das die Funktion "old-passwords" nach und nach auf den Webservern abgeschaltet wird!

    Ist diese Funktion in irgendeiner Weise relevant für Zen-Cart?
    Arbeite aktuell mit 1.3.7, ein Update auf 1.3.8 kommt zur Zeit leider auf Grund der vielen Veränderungen im Programmcode nicht in Frage!

  2. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.080
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 958

    Standard

    Zen-Cart ist von der Abschaltung dieser MySQL Funktion nicht betroffen.

    Allerdings ist das bei all-inkl anscheinend eine Vorbereitung auf die Umstellung auf PHP 5.3

    Von einer Umstellung auf PHP 5.3 bist Du betroffen.
    Für 1.3.8 gibt es folgenden Patch:
    https://www.zen-cart-pro.at/forum/showthread.php?t=7090

    Für 1.3.7 kannst Du nach dieser Anleitung vorgehen:
    http://www.zen-cart.com/forum/showthread.php?t=140960
    Wobei ein Update auf 1.3.8 mit anschließendem PHP 5.3 Patch sicher besser wäre.

    Solange nicht auf PHP 5.3 umgestellt wird, musst Du nichts machen. Es wäre aber gut, beim Provider nachzufragen, ob und wann sie wirklich umstellen wollen.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #3
    Padawan Stufe IV Avatar von Smartsoul
    Registriert seit
    23.05.2006
    Beiträge
    328
    Themen
    53
    DANKE
    0
    erhaltene Danke

    Standard

    Stehe vor dem selben Problem wie schuko80 und habe all-inkl. com deswegen gefragt: Bis wann soll die Umstellung auf php5.3 erfolgen?

    Weil webchills schrieb ja ...
    Zitat Zitat von webchills Beitrag anzeigen
    Allerdings ist das bei all-inkl anscheinend eine Vorbereitung auf die Umstellung auf PHP 5.3
    ... und so hatte ich das aus der Mail von all-inkl.com auch herausgelesen.
    ... durch die Einführung von php5.3 auf den Webservern ...
    Der Support von all-inkl.com hat mir gerade geantwortet:
    Eine Umstellung aller Server auf PHP5.3.1 ist nicht vorgesehen. Bei der Mail ging es nur um die Deaktivierung der MySQL-Option old-passwords.
    Werde nochmal nachhaken, vermute ich.

    Gruß

    Smartsoul
    Manchmal hab ich echt keinen Plan, aber dann hab ich immer noch mein Forum Danke an alle freundlichen HelferInnen!

  4. #4
    Padawan Stufe IV Avatar von Smartsoul
    Registriert seit
    23.05.2006
    Beiträge
    328
    Themen
    53
    DANKE
    0
    erhaltene Danke

    Standard

    Antwort von all-inkl.com

    ... alle Server haben bereits neben PHP 4 oder PHP 5.2, auch jetzt PHP 5.3 drauf. Nutzen kann man es aber nur dann, wenn man selbst es durch einen .htaccess Eintrag aktiviert.

    In der Regel können Sie zwischen mehreren PHP Versionen wählen. Das Umschalten zwischen den Versionen können Sie mittels einer .htaccess Datei (mit Punkt vorn!) bewerkstelligen, welche Sie im Hauptverzeichnis Ihres Webspaces anlegen. Folgende Einträge sind möglich:

    AddHandler php4-cgi .php (zum Arbeiten mit PHP4.4x) AddHandler php5-cgi .php (zum Arbeiten mit PHP5) AddHandler php53-cgi .php (zum Arbeiten mit PHP5.3.1)
    So ist das also!

    Gruß

    Smartsoul
    Manchmal hab ich echt keinen Plan, aber dann hab ich immer noch mein Forum Danke an alle freundlichen HelferInnen!

  5. #5
    Padawan Stufe I Avatar von oida-habara
    Registriert seit
    12.07.2007
    Ort
    Baden bei Wien
    Beiträge
    60
    Themen
    17
    DANKE
    0
    Erhaltene Danke: 0

    Standard

    Also ich find das toll, dass so eine Sache in so kurzer Zeit gelöst werden kann. Ich kenne da Foren und vor allem auch Provider, wo das Tage dauern würde. Dabei will ich ja gar nicht mal von UPC reden.....

  6. #6
    Padawan Stufe I Avatar von schuko80
    Registriert seit
    23.11.2007
    Beiträge
    27
    Themen
    9
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Hatte gestern Abend noch mal mit All-Inkl telefoniert, eine vollständige Umstellung auf PHP 5.3, also Abschaltung von 5.2 ist zur Zeit noch nicht geplant und wird erst durchgeführt, wenn es aus Sicherheitsrelevanten-Zwecken notwendig ist!

    Wichtig für mich ist zur Zeit, dass der Shop, trotz der Abschaltung dieser Funktion, weiter funktioniert! Und da habe ich dank euch ja nun Gewissheit

Ähnliche Themen

  1. Probleme bei der Anpassung und Design
    Von Andi im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 11
    Letzter Beitrag: 13.05.2004, 22:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1188 vom 02.12.2016
[Download]