Ergebnis 1 bis 3 von 3

Thema: SSL - Zertifikat Problem

  1. #1
    Padawan Anwärter Avatar von anom
    Registriert seit
    11.06.2005
    Beiträge
    2
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0

    Standard SSL - Zertifikat Problem

    Hallo miteinander,
    ich habe bei meinem Provider (1&1) das SSL-Zertifikat einrichten lassen.
    Was ich nicht wusste ist, dass das Zertifikat nur für - in meinem Fall
    https://questioner.de gilt und nicht für
    https://www.questioner.de .
    Nun habe ich eine Fehlermeldung wegen einem ungültigen Zertifikat.
    Bei 1&1 angefragt ereilte mich folgende Antwort:

    as Problem liegt daran, das Sie auf Ihrer Seite Links erstellt haben, z.B. zu Bildern, die relativ verlinken; im Quelltext Ihrer Startseite habe ich
    aber folgendes gefunden:

    <base href="https://www.questioner.de/shop/" />
    Das bedeutet, das ein Bild, das z.B. folgendermassen eingebaut ist:
    [img]includes/templates/blue_strip/images/block_left_01.gif[/img]
    auf die URL "https://www.questioner.de/shop/includes/templates/blue_strip/images/block_left_01.gif" zugreift - was die unten genannte Fehlermeldung er
    zeugt, da das Zertifikat nicht für "www.questioner.de" sondern für "questioner.de" ausgestellt ist. Teile der Homepage, die also auf die URL ohne
    www. zugreifen erzeugen keinen Fehler, Teile, die auf www. zugreifen erzeugen einen.

    Jeder Browser behandelt eine solche Situation unterschiedlich - je nachdem welche Einstellungen im Browser vorgenommen werden können sich auch gleic
    he Browser danach trotzdem unterschiedlich verhalten. Bei den meisten Browsern wird aber die Warnung angezeigt, da es sich ja um ein gefälschtes Zer
    tifikat handeln könnte.
    Nun hab ich inzwischen in der includes/configure.php alles auf "ohne www." geändert.
    Trotzdem erscheint der Fehler. :cry:

    Wo muss ich das noch ändern?
    Danke für eure Hilfe!

    Grüße
    Torsten

  2. #2
    Padawan Stufe I Avatar von lion23de
    Registriert seit
    19.02.2005
    Beiträge
    42
    Themen
    9
    DANKE
    0
    Erhaltene Danke: 0

    Standard

    Hallo,

    falls das Problem noch aktuell ist:

    Du musst in folgenden Dateien Einstellungen ändern:
    .../includes/configure.php
    dürfte bei Dir stehen
    define('HTTPS_SERVER', 'https://www.questioner.de');

    ändere das in
    define('HTTPS_SERVER', 'https://questioner.de');

    Nicht vergessen, die configure.php danach auf CHMOD444 zu setzen.

    Für den Adminbereich (falls Du dort das selbe Problem hast) ist es die Datei:
    .../admin/includes/configure.php

    hier musst Du zwei Zeilen ändern:
    define('HTTPS_SERVER', 'https://www.questioner.de');
    und zwei Zeilen darunter:
    define('HTTPS_CATALOG_SERVER', 'https://www.questioner.de');

    diese ändern in:
    define('HTTPS_SERVER', 'https://questioner.de');
    und
    define('HTTPS_CATALOG_SERVER', 'https://questioner.de');

    Damit müsste alles erledigt sein. Zumindest hat das bei mir auch geklappt (ebenfalls 1&1-Kunde) - bei mir war es genau andersherum.

    Gruß
    Peter

  3. #3
    Padawan Anwärter Avatar von anom
    Registriert seit
    11.06.2005
    Beiträge
    2
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard Danke, Peter...

    ... durch deine Antwort sind nun auch die letzten Problemchen gelöst.

    Für alle anderen, die vielleicht einmal vor diesem Problem stehen:

    - bei der Beantragung eines SSL Zertifikates genau überlegen, wie das Zertifikat beantragt wird - mit oder ohne www im Pfadnamen
    - alle relativen Verweise im html nach dem Zertifikat verwenden, sonst für das simple Laden eines Bildes zu einer (Fehler)Meldung.
    - die Änderungen (wie weiter oben im Post beschrieben) ggf. durchführen.

    Grüße
    Torsten

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.
Die amerikanische Zen-Cart Version berücksichtigt viele rechtliche Erfordernisse nicht, denen ein Onlineshop im deutschsprachigen Raum unterworfen ist. Daher wurde die deutsche Zen-Cart Version nicht nur bloß ins Deutsche übersetzt, sondern auch funktional auf die Anforderungen, die an Onlineshops in Deutschland, Österreich und der Schweiz gestellt werden, angepasst.

Die amerikanische Version ist extrem abgespeckt und stellt weiterführende Funktionalitäten durch zusätzliche Module bereit, die erst mühsam manuell installiert werden müssen. Zahlreiche häufig genutzte Erweiterungen und eigene Entwicklungen sind in der deutschen Zen Cart Version bereits vorinstalliert.
Die deutsche Zen-Cart Version bietet außerdem einen völlig multilingualen Adminbereich. Weitere für die deutsche Zen Cart Version angepasste Erweiterungen stehen in unserem Downloadbereich zur Verfügung.

Die deutsche Zen Cart Version wird seit 16 Jahren von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.6e deutsch
vom 26.07.2020
[Download]

unterstützen
Unterstütze die Weiterentwicklung der deutschen Zen Cart Version mit einer Spende!

Spende für die Weiterentwicklung der deutschen Zen Cart Version