Ergebnis 1 bis 6 von 6

Thema: EU Standard Banktransfer 2.0 - SQL Patch?

  1. #1
    Padawan Anwärter Avatar von jami1955
    Registriert seit
    12.06.2009
    Beiträge
    6
    Themen
    4
    DANKE
    0
    Erhaltene Danke: 0

    Standard EU Standard Banktransfer 2.0 - SQL Patch?

    Dieses Modul benötigt eine SQL-Patch zu arbeiten. Es braucht einen table TABLE_CONFIGURATION_LANGUAGE, die nicht da ist. Wo ist der SQL-Patch für dieses Modul - EU Standard Banktransfer 2.0 ?

    If you can answer in English that's even better...

  2. #2
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.055
    Themen
    81
    DANKE
    3
    Erhaltene Danke: 954

    Standard

    This module is for the GERMAN Zen-Cart version. If you do not have the table configuration_language you are using the english version from zen-cart.com.
    So you should better check out the zen-cart.com download section.
    http://www.zen-cart.com/index.php?ma...roducts_id=209
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #3
    Padawan Anwärter Avatar von jami1955
    Registriert seit
    12.06.2009
    Beiträge
    6
    Themen
    4
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    While it is true the original installation 1.3.9d is from zencart.com, the German Language Pack was installed and is running otherwise successfully. Perhaps there could be some coordination between the modules written and posted here on this site, and the way that German Language Pack from Zencart.com operates.

  4. #4
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.055
    Themen
    81
    DANKE
    3
    Erhaltene Danke: 954

    Standard

    A german language pack has nothing to do with the German Zen-Cart Version we are developing here. Our version has a different database structure to enable a multilanguage admin. And the modules in our download section are especially for this multilanguage version. Even if you have installed a German language pack Your main System remains an english Zen-Cart lacking a multilanguage admin. So you cannot use any modules from our download section.
    BlackBerry9500/5.0.0.580 Profile/MIDP-2.1 Configuration/CLDC-1.1 VendorID/137
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  5. #5
    Padawan Anwärter Avatar von jami1955
    Registriert seit
    12.06.2009
    Beiträge
    6
    Themen
    4
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Webchills: I've installed several zen carts in Germany, they all have Deutsche sprache admins, otherwise German speaking clients could not use them. The German Language Pack does indeed have an admin section in German. See screenshot.

    I have also used the Germanbanktransfer mod also known as Lastschriftverfahren - successfully, but that was on 1.3.8a. I have a feeling that the problem lies with the version, as zen-cart.at is stating the
    Die aktuelle deutsche Zen-Cart Version. Derzeit ist das Zen-Cart 1.3.8.
    which is now one version behind the current version 1.3.9d. Anyway, I downloaded and installed the mod eustandardtransfer which is very similar to the germanbanktransfer mod, but it is working fine on this version. Thanks for the English answers.
    JSC
    Boulder, CO, USA

  6. #6
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.055
    Themen
    81
    DANKE
    3
    Erhaltene Danke: 954

    Standard

    Just to clarify:

    There is a difference between language definitions in language files and language definitions in the database. And there is a difference between multilanguage and real multilanguage.

    The German language pack which you have installed does only add german language files and does not change anything in the database structure.

    The German Zen-Cart version is not only an english Zen-Cart with some german language files. There is an additional table called configuration_language and an additional field called language_id in the configuration_group. And of course some changes in the code to reflect these database changes. There are many other improvements as well but lets focus here on the language things.

    If you switch your admin to German and look at Catalog > Product Types in your installation (Webshop > Artikeltypen in German) and click on edit layout (Layout bearbeiten in German) you will see something like this:



    All of these options are in English as they are coming from the configuration table in the database.

    If you do the same in our German Zen-Cart Version it will look like this:




    These German definitions are coming from the additional configuration_language table in the database.
    If you switch our admin section to englisch they will appear in english.

    We fill these fields during the Zen-Cart installation so almost every option in the deeper configuration settings are really multilanguage. English clients have everything in English, German clients everything in German. Thats multilanguage

    This functionality can be used for additional modules too which are installed later.

    Install Image Handler in your installation and you will see something like this:



    No matter if you switch your admin to english or german, your settings will always be English only. And that cannot be cured with language files

    Install a multilanguage Image Handler version from here in a German Zen-Cart and you will see something like this:



    Switch the admin to english and you will se the English settings.

    That's real multilanguage.

    Some modules in our download section do not care about real multilanguage. They simply have a translation in German for the values that are written in the normal configuration table. So no matter if you switch your admin to English or German the configuration settings of these modules are always in German. These modules will all work without any problems in an English Zen-Cart.

    Some other modules in our download section do care about real multilanguage and use the additional configuration_language table. EU Standard Bank Transfer is such a module which wants to write its German configuration definitions to the configuration_language table. This will of course fail in an English Zen-Cart which does not know this table.

    Cheers

    webchills
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

Ähnliche Themen

  1. PHP 5.3 Patch für Zen-Cart 1.3.8
    Von webchills im Forum News und Ankündigungen
    Antworten: 0
    Letzter Beitrag: 10.11.2009, 09:30
  2. Nach SQL Patch Installation Datenbank Fehlermeldung
    Von Lissy73 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 2
    Letzter Beitrag: 23.01.2008, 09:08
  3. SQL Patch Befehl
    Von elpego im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 1
    Letzter Beitrag: 19.01.2008, 13:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1184 vom 01.09.2016
[Download]