Ergebnis 1 bis 10 von 10

Thema: ZC 1.3.9 und JTL Connector

  1. #1
    Padawan Anwärter Avatar von starclean
    Registriert seit
    04.02.2011
    Beiträge
    3
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0

    Standard ZC 1.3.9 und JTL Connector

    Hallo ihr lieben,
    erstens wollt ich "als kleinen schutz" sagen das ich neu hier bin!

    So ich habe folgendes Problem, wo die Herrschaften bei JTL im Forum mir auch irgendwie nicht weiter helfen konnten.

    So mein Shop läuft ohne Fehler!
    Habe die JTL Connector Datei ins richtige Verzeichnis gepackt!
    Der ist auch schon Installiert (manuelle Installation!)!
    So mein Problem ist jetzt aber wenn ich dort die Admindatei aufrufen will, kommt immer folgender Fehler:

    Serverfehler

    Beim Abrufen von http://www.starcleanberlin.de/shop/j...ector/admin/index.php ist auf der Website ein Fehler aufgetreten. Möglicherweise wird sie gerade gewartet oder ist falsch konfiguriert.

    Vorschläge:
    Laden Sie diese Webseite später erneut.
    Weitere Informationen zu diesem Fehler
    Unten finden Sie die ursprüngliche Fehlermeldung

    HTTP-Fehler 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    Jetzt gab es da ja schon ein "schlaumeier" der mir den Fehler erklärt hat und meinte das ein Fehler im Pfad ist, ist es aber nicht! ich rufe das richtige verzeichnis dauernd auf aber es kommt immer und immer wieder dieser Fehler!

    Ich bin langsam am verzweifeln!

  2. #2
    Padawan Anwärter Avatar von starclean
    Registriert seit
    04.02.2011
    Beiträge
    3
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Habe vergessen zu erwähnen, das wenn ich den Ordner JTL-connector in "admin"/includes/modules/jtlwawi_connector/install/index.php speicher, kommt immer folgende Meldung:
    Forbidden

    You don't have permission to access .../includes/modules/jtlwawi_connector/install/index.php on this server.

    So habe jetzt die easysales Dateien erstmal wieder von der Datenbank geschmissen, sprich ich muss diesen connector neu Installieren!

  3. #3
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.093
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 962

    Standard

    Es dürfte sich bei JTL Wawi nicht herumgesprochen haben, dass das admin Verzeichnis einer Zen-Cart Installation immer umbenannt ist. Auch in der aktuellen Version dieses Connectors steht admin mehrfach hardcodet drin.

    Ich würde das ganze Verzeichnis jtlwawi_connector nicht nach DEINADMIN/includes/modules laden sondern ins Shophauptverzeichnis.
    Folgende Änderungen sind nötig:

    jtlwawi_connector/paths.php:
    Original:
    Code:
    //Pfad zum Shop Root
    define (DOCROOT_PATH,"../../../../../");
    Ändern auf den vollständigen Pfad (so wie in der Zen-Cart configure.php):
    Code:
    //Pfad zum Shop Root
    define (DOCROOT_PATH,"/home/xxx/xxx/html/xxx/");
    jtlwawi_connector/install/index.php:
    Original:
    Code:
    // include server parameters
    require(DOCROOT_PATH.'admin/includes/configure.php');
    Ändern auf:
    Code:
    // include server parameters
    require(DOCROOT_PATH.'DEINADMIN/includes/configure.php');
    jtlwawi_connector/admin/admininclude.php:
    Original:
    Code:
    // include server parameters
    require(DOCROOT_PATH.'admin/includes/configure.php');
    Ändern auf:
    Code:
    // include server parameters
    require(DOCROOT_PATH.'DEINADMIN/includes/configure.php');
    jtlwawi_connector/dbeS/syncinclude.php
    Original:
    Code:
    // include server parameters
    require(DOCROOT_PATH.'admin/includes/configure.php');
    Ändern auf:
    Code:
    // include server parameters
    require(DOCROOT_PATH.'DEINADMIN/includes/configure.php');
    Vielleicht gibt es noch mehr Dateien, wo der admin hardcodiert drinsteht, mag das jetzt nicht alles durchschauen.

    Die weitere Funktionalität kann ich nicht prüfen, da ich das nicht verwende, vielleicht können andere User da mehr beitragen.
    Es wär jedenfalls schön, wenn dieser Connector mal wirklich auf das aktuelle Zen-Cart Verhalten angepasst würde. Es ist nicht schön, da den Adminnamen reinschreiben zu müssen, wäre auch eleganter möglich.
    Geändert von webchills (10.02.2011 um 20:01 Uhr)
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  4. #4
    Padawan Anwärter Avatar von starclean
    Registriert seit
    04.02.2011
    Beiträge
    3
    Themen
    1
    DANKE
    0
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Ja habe deine Ratschläge soweit befolgt! Aber folgende Fehlermeldung kommt immer noch:

    Die Website kann diese Seite nicht anzeigen.
    HTTP 500
    Wahrscheinlichste Ursachen:
    •Die Website wird momentan gewartet.
    •Die Website enthält einen Programmierfehler.

    Mögliche Vorgehensweise:
    Aktualisieren Sie die Seite.

    Wechseln Sie zur vorherigen Seite.

    Weitere Informationen

    Dieser Fehler (HTTP 500 Interner Serverfehler) bedeutet, dass die Website, die Sie besuchen möchten, ein Serverproblem hat, durch das die Anzeige der Webseite verhindert wird.

    Weitere Informationen über HTTP-Fehler erhalten Sie in der Hilfe.

    Ick weiss nicht, habe die vermutung das ich bei jtlwawi_connector/paths.php
    den falschen Pfad eingebe!

    Wo steht den der Pfad genau in der Zen-Cart configure.php??
    Also welche Zeile?

  5. #5
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.093
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 962

    Standard

    includes/configure.php:

    Code:
    //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
      define('DIR_FS_CATALOG', '/xxx/xxx/xxx/xxx/xxx/');
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  6. #6
    Padawan Stufe VI Avatar von jjuno
    Registriert seit
    26.09.2008
    Beiträge
    758
    Themen
    14
    DANKE
    4
    Erhaltene Danke: 45

    Standard

    Servus,

    ich verwende den JTL-Connector mit 1.38a und zwar ohne Probleme.

    Die Installation habe ich durchgeführt wie in der JTL Wiki beschrieben und zwar nach
    dem .htaccess geschützten Adminbereich. In dem Wiki steht zwar nur OSC dahinter,
    geht aber für Zen Cart genau so.

    Den Connector habe ich in Shop Hauptverzeichniss gelegt und auch dort die .../install/.. aufgerufen.

    Die Änderungen an der path.php wie von webchills beschrieben habe ich nicht gemacht. Habe diese genau wie in der Installationsanleitung von JTL beschrieben eingetragen.

    Sieht so aus:

    //Pfad zum Shop Root
    define (DOCROOT_PATH,"../../");

    weil nicht im Adminbereich, welcher ja bekanntlich .htaccess geschützt ist.

    Die Installation ist Watschn einfach, wie man in Oberbayern zu sagen pflegt.

  7. #7
    Padawan Stufe VI Avatar von jjuno
    Registriert seit
    26.09.2008
    Beiträge
    758
    Themen
    14
    DANKE
    4
    Erhaltene Danke: 45

    Standard

    Ergänzend zum Thema, unter Xampp als Hostsystem mit einer 1.39 Shop-Version hat
    der Zugriff über den Standard Connector von JTL (Client Windows 7) funktioniert. Habe
    das ganze gerade probiert, da bei uns ja auch demnächst ein Update von 1.38 auf
    1.39 ansteht.

    Falls jemand mit Linux Erfahrung das Thema liest, suche noch immer eine WaWi die
    unter Linux tadellos funktioniert und über einen Connector zu Zen-Cart verfügt.

  8. #8
    Padawan Anwärter Avatar von Marcus1977
    Registriert seit
    09.11.2009
    Beiträge
    18
    Themen
    7
    DANKE
    1
    erhaltene Danke

    Frage Das gleiche

    Ich habe das gleiche Problem.

    Das einzige was bei mir einen Erfolg gebracht hat ist die .htaccess zu bearbeiten im admin Verzeichnis und allen weiteren Unterverzeichnisse.

    Dort habe ich einen TCP Allow mit meiner IP eingetragen. Ist ja eigentlich auch logisch da ja die Schnittstelle egal wo sie liegt aufs admin Verzeichnis zugreift.

    Das ist auch in den apache Logs ersichtlich. Derzeit kann ich mir nur so helfen entweder für den Sync Vorgang die .htaccess umzubenennen oder jedes Mal wieder meine IP einzutragen. Was mit dynamischer IP sehr lästig und zeitaufwendig und Risikoreich ist. Für eine Lösung oder Idee wäre ich auch dankbar.

    Ich denke dass es eine Lösung gibt aber ich komm nicht dahinter...

    Danke schon mal im Voraus.

    Gruß

  9. #9
    Padawan Anwärter Avatar von Charly
    Registriert seit
    02.01.2011
    Beiträge
    17
    Themen
    4
    DANKE
    4
    Erhaltene Danke: 0

    Standard

    Zitat Zitat von jjuno Beitrag anzeigen
    Servus,

    ich verwende den JTL-Connector mit 1.38a und zwar ohne Probleme.

    Die Installation habe ich durchgeführt wie in der JTL Wiki beschrieben und zwar nach
    dem .htaccess geschützten Adminbereich. In dem Wiki steht zwar nur OSC dahinter,
    geht aber für Zen Cart genau so.

    Den Connector habe ich in Shop Hauptverzeichniss gelegt und auch dort die .../install/.. aufgerufen.

    Die Änderungen an der path.php wie von webchills beschrieben habe ich nicht gemacht. Habe diese genau wie in der Installationsanleitung von JTL beschrieben eingetragen.

    Sieht so aus:

    //Pfad zum Shop Root
    define (DOCROOT_PATH,"../../");

    weil nicht im Adminbereich, welcher ja bekanntlich .htaccess geschützt ist.

    Die Installation ist Watschn einfach, wie man in Oberbayern zu sagen pflegt.
    Hast recht das klappt so.
    Man muss jedoch noch in der Index.PHP Zeile 20(jtlwawi_connector/Install)
    require(DOCROOT_PATH.'admin/includes/configure.php');den Eintrag in
    require(DOCROOT_PATH.'dein Admin/includes/configure.php');aendern.

  10. #10
    Padawan Anwärter Avatar von delitv
    Registriert seit
    23.03.2013
    Beiträge
    1
    Themen
    0
    DANKE
    0
    Erhaltene Danke: 0

    Standard

    Also nach 3 Stunden hat die Installation erfolgreich geklappt nur wenn ich meinen Shop nun mit JTL Wawi verbinden will kommt immer:
    1.png2.png


    Bitte meinen Beitrag in folgendes Thema verschieben - Danke :

    https://www.zen-cart-pro.at/forum/th...-verbidung-oky
    Geändert von delitv (23.03.2013 um 18:50 Uhr)

Ähnliche Themen

  1. AttributeModelnumbers_v0.2 für 1.3.9
    Von dema im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 4
    Letzter Beitrag: 05.02.2011, 14:15
  2. Für Zen-Cart 1.3.9 ist mindestens PHP 5.2.3 nötig!
    Von webchills im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 0
    Letzter Beitrag: 03.12.2010, 13:19
  3. Ist 1.3.9 bereits mit moneybookers kompatibel?
    Von CETIMOND im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 6
    Letzter Beitrag: 08.09.2010, 15:22
  4. JTL connector
    Von Malinka im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 6
    Letzter Beitrag: 19.10.2009, 06:06
  5. Jtl-wawi Connector - Brauche ganz dringend Eure Hilfe
    Von spatz im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 5
    Letzter Beitrag: 25.11.2008, 22:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1188 vom 02.12.2016
[Download]