Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 17 von 17

Thema: PHP Warning: strpos() expects parameter 1 to be string

  1. #11
    Padawan Stufe I Avatar von dagoberti
    Registriert seit
    05.02.2011
    Ort
    Niederösterreich
    Beiträge
    51
    Themen
    13
    DANKE
    23
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Lieber Webchills

    danke - facebook ist nun in Ordnung - es kommen keine error logs mehr


    Das alte Datenbanksicherungstool habe ich auch geändert - nur kommt da nun folgende Info in der Admin:

    HINWEIS: Sie haben kein SSL aktiv. Alle Downloads von dieser Seite werden NICHT verschlüsselt. Sicherungen und Wiederherstellungen werden problemlos funktionieren, allerdings stellt das Nichtverwenden von SSL ein Sicherheitsrisiko dar.

  2. #12
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.092
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 961

    Standard

    Das ist keine Fehlermeldung sondern ein Hinweis, dass ohne SSL theoretisch der Inhalt der Datenbanksicherung beim Download von bösen Buben mitgeschnitten werden könnte. Generell ist ein Onlineshop ohne SSL vor allem für die Kunden eine Zumutung, da sie ihre Daten unverschlüsselt eingeben müssen. Ein Shop ohne SSL ist nicht mehr zeitgemäß. Auch für den Adminbereich ist SSL eine wichtige Absicherung.

    posted via Tapatalk
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  3. #13
    Padawan Stufe I Avatar von dagoberti
    Registriert seit
    05.02.2011
    Ort
    Niederösterreich
    Beiträge
    51
    Themen
    13
    DANKE
    23
    Erhaltene Danke: 0
    Erstellt von

    Standard

    sorry wenn ich jetzt "blöd" frage - d.h. der Webshop ist generel nicht mit ssl verschlüsselt? Die Meldung war ja vorher nicht da - war der Shop vorher mit dem Error der alten Datenbank SSL-Verschlüsselt und ist jetzt aufgrund der Änderung nicht mehr?

    oder kann ich das irgendwo einstellen?

  4. #14
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.092
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 961

    Standard

    Das neue Tool weist nur darauf hin, dass SSL nicht aktiv ist, das alte hat das nicht gemacht. Um SSL nutzen zu können brauchst Du ein SSL Zertifikat, das kann man nicht einfach einschalten. Nähere Auskunft zu den Kosten dafür gibt Dein Provider.

    posted via Tapatalk
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  5. Folgender User sagt Danke zu webchills für den nützlichen Beitrag:

    dagoberti (12.08.2011)

  6. #15
    Padawan Stufe I Avatar von dagoberti
    Registriert seit
    05.02.2011
    Ort
    Niederösterreich
    Beiträge
    51
    Themen
    13
    DANKE
    23
    Erhaltene Danke: 0
    Erstellt von

    Standard Datenbanksicherung - Button Sicherung

    Zitat Zitat von webchills Beitrag anzeigen
    Wenn Du diese Meldungen auch noch wegbekommen willst, die kommen von einem veralteten Datenbanksicherungstool, das in 1.3.9 noch vorhanden ist (Tools > Datenbanksicherung)
    Spiele die angehängten Dateien ein (Ordner admin vorher auf Deinen admin Ordner umbenennen, es werden die veralteten Dateien dieses Tools überschrieben), ist im SVN bereits behoben.

    Lieber Webchills

    nach Änderung der veralteten Dateien ist nun der Button SICHERUNG ( "button_backup.gif" ) nicht mehr ersichtlich, wenn ich eine Datenbanksicherung durchführen möchte.

    Der Button ist in der richtigen Datei vorhanden. Pfad: admin/includes/languages/german/images/buttons/button_backup.gif


    Kann somit keine Sicherungen der Datenbank mehr durchführen.

    Bitte um Info - dankeschön

  7. #16
    Jedi-Ritter Avatar von webchills
    Registriert seit
    30.10.2004
    Ort
    Österreich
    Beiträge
    6.092
    Themen
    85
    DANKE
    3
    Erhaltene Danke: 961

    Standard

    Die Sicherung ist nur möglich wenn das backup Verzeichnis beschreibbar ist. Überprüfe ob DEINADMIN/backups chmod 777 hat.
    Ebenso ist die Sicherung nur möglich, wenn der safe_mode off ist.
    Überprüfe unter Tools > Serverinfo, on der safe_mode aktiv ist. Hier muss stehen:
    PHP Safe Mode: Off
    Ist das On, dann mit dem Provider reden, ob und wie der Safe Mode deaktiviert werden kann.
    Wenn diese Voraussetzungen nicht erfüllt sind, dann wird der Button gar nicht erst angezeigt, weil eine Sicherung ohnehin nicht möglich ist.
    !!! kostenloser Support ausschließlich im Forum - Nicht per Email, nicht per Telefon und nicht per PM !!!

  8. #17
    Padawan Stufe I Avatar von dagoberti
    Registriert seit
    05.02.2011
    Ort
    Niederösterreich
    Beiträge
    51
    Themen
    13
    DANKE
    23
    Erhaltene Danke: 0
    Erstellt von

    Standard

    Lieber Webchills

    ich habe nun wie beschrieben Safe mode auf off und Ordner backups auf chmod 777

    Der Sicherungsbutton ist nun da - nur leider kann noch immer keine Sicherung gemacht werden

    es kommt folgende Errormeldung - eine Idee dazu?
    (ich hab die Installation des Backup Tools neu nochmals durchgemacht - ohne Erfolg - der Error bleibt).



    Result code: 127 0 => sh: mysqldump: command not found
    FEHLER: Konnte das MYSQLDUMP Backup Tool nicht finden. BACKUP FEHLGESCHLAGEN. FEHLER: This backup script seldom works when safe_mode is enabled or open_basedir restrictions are in effect.
    If you get no errors doing a backup, check to see whether the file is less than 200kb. If so, then the backup is likely unreliable.

Seite 2 von 2 ErsteErste 12

Ähnliche Themen

  1. Fehler HTTP 500
    Von richards35 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 7
    Letzter Beitrag: 22.04.2011, 21:23
  2. Ultimate SEO URLs 2.105 - Kategorien-Links fehlerhaft
    Von nc-schoenst10 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 24
    Letzter Beitrag: 20.01.2010, 17:50
  3. weiße Seite bei Installation
    Von heavendreams im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 8
    Letzter Beitrag: 09.06.2009, 15:35
  4. Fehlermeldung "Zero Sized Reply" nach Lizenzbestätigung
    Von MySigma im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 3
    Letzter Beitrag: 20.10.2008, 12:40
  5. Kein Zugang zum Admin-Bereich nach Install von 1.3.6 DE
    Von taifun89343 im Forum Archivierte Beiträge Zen-Cart Support
    Antworten: 22
    Letzter Beitrag: 12.01.2007, 21:11

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
zen-cart-pro.at
Zen Cart ist eine kostenlose unter der GPL-Lizenz veröffentlichte Open-Source Shopsoftware. Das System wird in den USA entwickelt, die amerikanische Website dazu ist www.zen-cart.com

Die deutsche Zen-Cart Version, um die es hier auf zen-cart-pro.at geht, ist eine Anpassung der amerikanischen Version an die Bedürfnisse von Onlineshopbetreibern im deutschsprachigen Raum.

Die deutsche Zen Cart Version wird von einem Team von Entwicklern in Österreich und Deutschland betreut, weiterentwickelt und supportet und steht kostenlos in unserem Downloadbereich zur Verfügung.

[mehr]
Follow Us
  • zen-cart-pro-at auf Twitter
  • zen-cart-pro-at auf Github
  • zen-cart-pro-at auf SourceForge
Aktuelle Version
Zen Cart 1.5.5 deutsch
Revision 1188 vom 02.12.2016
[Download]